aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-04 03:59:01 +0800
committergerald <gerald@FreeBSD.org>2009-01-04 03:59:01 +0800
commitd2ade80e47f36f30a8c58ba05973620cec65fe49 (patch)
tree3a511252088db04f4ea0002b873164f5cd6a993f /lang/gcc
parent566c6dced88933c9b107185a90073ed1887a7018 (diff)
downloadfreebsd-ports-gnome-d2ade80e47f36f30a8c58ba05973620cec65fe49.tar.gz
freebsd-ports-gnome-d2ade80e47f36f30a8c58ba05973620cec65fe49.tar.zst
freebsd-ports-gnome-d2ade80e47f36f30a8c58ba05973620cec65fe49.zip
Replace CONFLICTS=gcc-2.95.*, which actually is too late to prevent
us running into build problems, by an earlier check (pre-extract). Suggested by: pav
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index d8487bef6028..a4a8f5347454 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -28,9 +28,6 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64
-# Building libgcj with lang/gcc295 installed is causing a failure about
-# "hidden symbol `__eprintf'" in libgcc.a(_eprintf.o).
-CONFLICTS= gcc-2.95.*
USE_BISON= build
USE_BZIP2= yes
USE_GMAKE= yes
@@ -150,6 +147,14 @@ pre-everything::
fi
.endif
+pre-extract:
+ @# Building libgcj with lang/gcc295 installed is causing a failure
+ @# about "hidden symbol `__eprintf'" in libgcc.a(_eprintf.o).
+ @if type gcc295 >/dev/null ; then \
+ echo "This port will not build in the presence of lang/gcc295."; \
+ exit 1; \
+ fi
+
post-patch:
@${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
${SRCDIR}/gcc/version.c