aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-09-28 05:45:10 +0800
committergerald <gerald@FreeBSD.org>2010-09-28 05:45:10 +0800
commit84205531a3f0363e5c60b15b045dbf5e9ad033da (patch)
tree027cb09f6fbdf1dc9c082da4bc48e495cdd0a5ee /lang/gcc
parent70dc4c1988c9086a70e3782e30f990bf24d40435 (diff)
downloadfreebsd-ports-gnome-84205531a3f0363e5c60b15b045dbf5e9ad033da.tar.gz
freebsd-ports-gnome-84205531a3f0363e5c60b15b045dbf5e9ad033da.tar.zst
freebsd-ports-gnome-84205531a3f0363e5c60b15b045dbf5e9ad033da.zip
Replace the explicit build dependency on devel/binutils by USE_BINUTILS.
Submitted by: bf
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index f24de7c1802b..667019f2df28 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -21,7 +21,6 @@ COMMENT= GNU Compiler Collection 4.6
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
-BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
@@ -33,6 +32,7 @@ VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 ia64 sparc64
+USE_BINUTILS= yes
USE_BISON= build
USE_BZIP2= yes
USE_GMAKE= yes