aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc
diff options
context:
space:
mode:
authorjmmv <jmmv@FreeBSD.org>2015-11-23 05:06:54 +0800
committerjmmv <jmmv@FreeBSD.org>2015-11-23 05:06:54 +0800
commit3bb8b3c4c461d52be831c9cd5a2f7bb43f292557 (patch)
tree6630e6ffcc7ed009ba3db4c352fae07561c1416f /lang/gcc
parent6698ba1a74bddefc655755efa22ec7d3776d8c04 (diff)
downloadfreebsd-ports-gnome-3bb8b3c4c461d52be831c9cd5a2f7bb43f292557.tar.gz
freebsd-ports-gnome-3bb8b3c4c461d52be831c9cd5a2f7bb43f292557.tar.zst
freebsd-ports-gnome-3bb8b3c4c461d52be831c9cd5a2f7bb43f292557.zip
Add a MULTILIB option to gcc{,48,49,5} for powerpc64
This change is the same as r400632, which updated gcc[56]-devel, but now for gcc{,48,49,5}. This change is the second attempt at doing this: the first attempt went in r401072 and was reverted in r401074 because the diff was bogus and enabled the new MULTILIB option under all platforms instead of just powerpc64. This fixes the build of gcc{,48,49,5} under powerpc64 when the system is built without the lib32 libraries. More in detail: If the system is built with lib32 support (WITH_LIB32, which is the default), building gcc from ports results in a compiler that can target both 64-bit and 32-bit binaries on powerpc64. However, when lib32 support is disabled (WITHOUT_LIB32), gcc should only be built with 64-bit support or otherwise the build fails. To fix this, explicitly disable 32-bit support when /usr/lib32 is not present and add a MULTILIB option (which is only defined for powerpc64 when 32-bit support is possible and defaults to yes to preserve the current behavior) to allow the user to explicitly control this feature. Approved by: gerald (maintainer), bdrewery (mentor), andreast Differential Revision: https://reviews.freebsd.org/D3952
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 3af4bab4c988..a82fa39a5169 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gcc
PORTVERSION= 4.8.5
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
@@ -47,6 +48,15 @@ OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
+.if exists(/usr/lib32/libc.so)
+OPTIONS_DEFINE_powerpc64= MULTILIB
+OPTIONS_DEFAULT_powerpc64= MULTILIB
+MULTILIB_DESC= Build support for 32-bit and 64-bit target types
+MULTILIB_CONFIGURE_ENABLE= multilib
+.else
+CONFIGURE_ARGS+= --disable-multilib
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"