aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcl/Makefile
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2004-07-19 23:52:08 +0800
committermarkm <markm@FreeBSD.org>2004-07-19 23:52:08 +0800
commit483300fd73cfc906c0f9e745cf24dc20ebeb829c (patch)
treea01067b61608454d23f73cec438dc57fb5a64d88 /lang/gcl/Makefile
parenteab29d5163ee1b95d995c84daed11e0ec8b0b6e8 (diff)
downloadfreebsd-ports-gnome-483300fd73cfc906c0f9e745cf24dc20ebeb829c.tar.gz
freebsd-ports-gnome-483300fd73cfc906c0f9e745cf24dc20ebeb829c.tar.zst
freebsd-ports-gnome-483300fd73cfc906c0f9e745cf24dc20ebeb829c.zip
Upgrade to GCL 2.6.3.
Diffstat (limited to 'lang/gcl/Makefile')
-rw-r--r--lang/gcl/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
index 60b5f841c388..2efcc8d63a77 100644
--- a/lang/gcl/Makefile
+++ b/lang/gcl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcl
-PORTVERSION= 2.5.3
-PORTREVISION= 1
+PORTVERSION= 2.6.3
CATEGORIES= lang tcl84 tk84
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gcl
@@ -20,12 +19,11 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
ONLY_FOR_ARCHS= i386 sparc64
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOCONF_VER= 259
USE_GMAKE= yes
USE_XLIB= yes
CONFIGURE_ARGS=--prefix=${PREFIX} \
--enable-machine=FreeBSD \
- --enable-ansi \
--infodir=${PREFIX}/info \
--enable-info=${PREFIX}/info \
--enable-tkconfig=${LOCALBASE}/lib/tk8.4 \
@@ -46,12 +44,11 @@ PLIST_SUB= GCL_VER=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
pre-configure:
${RM} -f ${WRKSRC}/configure
- ${SED} -i '.PRE-SED' -e 's|@@CFLAGS@@|${CFLAGS}|' ${WRKSRC}/h/FreeBSD.defs
+ ${SED} -i '' \
+ -e 's|@@CFLAGS@@|${CFLAGS} -I${LOCALBASE}/include|' \
+ -e 's|@@LOCALLIBS@@|-L${LOCALBASE}/lib -lm -lreadline|' \
+ ${WRKSRC}/h/FreeBSD.defs
.include <bsd.port.post.mk>