aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gdc
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-01-13 15:55:03 +0800
committerdaichi <daichi@FreeBSD.org>2005-01-13 15:55:03 +0800
commit96625ab9aa492dd232c1b93d2a8f8220991165f1 (patch)
tree792bc50ab8fd551a20e58bf3500f16aee96abdb4 /lang/gdc
parentbc6f44ea01550a54f6e241018174bcf51277cd70 (diff)
downloadfreebsd-ports-gnome-96625ab9aa492dd232c1b93d2a8f8220991165f1.tar.gz
freebsd-ports-gnome-96625ab9aa492dd232c1b93d2a8f8220991165f1.tar.zst
freebsd-ports-gnome-96625ab9aa492dd232c1b93d2a8f8220991165f1.zip
o update to 0.10
o build fail problem fixed Submitted by: ozawa@ongs.co.jp
Diffstat (limited to 'lang/gdc')
-rw-r--r--lang/gdc/Makefile5
-rw-r--r--lang/gdc/distinfo4
-rw-r--r--lang/gdc/files/patch-gengtype-yacc.y12
-rw-r--r--lang/gdc/pkg-plist211
4 files changed, 96 insertions, 136 deletions
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index 77ec0a57f0c7..aaa0804738d0 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gdc
-PORTVERSION= 0.9
+PORTVERSION= 0.10
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC} \
http://home.earthlink.net/~dvdfrdmn/d/:gdc \
@@ -22,7 +22,8 @@ EXTRACT_ONLY= gcc-core-${GCC_VERSIONSTRING}.tar.bz2 \
MAINTAINER= daichi@FreeBSD.org
COMMENT= D Front End for GCC
-BUILD_DEPENDS= gcc34:${PORTSDIR}/lang/gcc34
+BUILD_DEPENDS= gcc34:${PORTSDIR}/lang/gcc34 \
+ bison:${PORTSDIR}/devel/bison
RUN_DEPENDS= gcc34:${PORTSDIR}/lang/gcc34
ONLY_FOR_ARCHS= i386 amd64 alpha
diff --git a/lang/gdc/distinfo b/lang/gdc/distinfo
index 34356559ad01..1c13213a7ddd 100644
--- a/lang/gdc/distinfo
+++ b/lang/gdc/distinfo
@@ -1,5 +1,5 @@
-MD5 (gdc-0.9.tar.bz2) = 3d6efa71a0dc7e795a886307498b2505
-SIZE (gdc-0.9.tar.bz2) = 741192
+MD5 (gdc-0.10.tar.bz2) = ece1b586d23770d9999b95f8026e2ba9
+SIZE (gdc-0.10.tar.bz2) = 750490
MD5 (gcc-core-3.4-20050107.tar.bz2) = 4746d8f5dde3d09ac840a9cbfa1d5760
SIZE (gcc-core-3.4-20050107.tar.bz2) = 10978045
MD5 (gcc-g++-3.4-20050107.tar.bz2) = 2a646e4139d858738b5748f5477a6842
diff --git a/lang/gdc/files/patch-gengtype-yacc.y b/lang/gdc/files/patch-gengtype-yacc.y
new file mode 100644
index 000000000000..4afaae159533
--- /dev/null
+++ b/lang/gdc/files/patch-gengtype-yacc.y
@@ -0,0 +1,12 @@
+--- gcc/gengtype-yacc.y.orig Fri Sep 20 00:33:24 2002
++++ gcc/gengtype-yacc.y Tue Apr 22 09:11:27 2003
+@@ -24,6 +24,9 @@
+ #include "system.h"
+ #include "gengtype.h"
+ #define YYERROR_VERBOSE
++
++#define malloc xmalloc
++#define realloc xrealloc
+ %}
+
+ %union {
diff --git a/lang/gdc/pkg-plist b/lang/gdc/pkg-plist
index 80b44581f395..06f1bfac4084 100644
--- a/lang/gdc/pkg-plist
+++ b/lang/gdc/pkg-plist
@@ -1,37 +1,21 @@
bin/gdc
bin/cc1d
-include/d/unittest.d
-include/d/object.d
-include/d/gcstats.d
-include/d/crc32.d
-include/d/etc/c/recls/win32.mak
include/d/etc/c/recls/recls.h
-include/d/etc/c/recls/recls_api.cpp
-include/d/etc/c/recls/recls_api_unix.cpp
-include/d/etc/c/recls/recls_api_win32.cpp
include/d/etc/c/recls/recls_assert.h
include/d/etc/c/recls/recls_compiler.h
include/d/etc/c/recls/recls_compiler_dmc.h
include/d/etc/c/recls/recls_compiler_gcc.h
include/d/etc/c/recls/recls_debug.h
include/d/etc/c/recls/recls_defs.h
-include/d/etc/c/recls/recls_fileinfo.cpp
-include/d/etc/c/recls/recls_fileinfo_unix.cpp
-include/d/etc/c/recls/recls_fileinfo_win32.cpp
-include/d/etc/c/recls/recls_internal.cpp
include/d/etc/c/recls/recls_internal.h
include/d/etc/c/recls/recls_language.h
include/d/etc/c/recls/recls_platform.h
include/d/etc/c/recls/recls_platform_types.h
include/d/etc/c/recls/recls_retcodes.h
include/d/etc/c/recls/recls_unix.h
-include/d/etc/c/recls/recls_util.cpp
include/d/etc/c/recls/recls_util.h
-include/d/etc/c/recls/recls_util_unix.cpp
-include/d/etc/c/recls/recls_util_win32.cpp
include/d/etc/c/recls/recls_win32.h
-include/d/etc/c/recls/linux.mak
-include/d/etc/c/stlsoft/winstl_tls_index.h
+include/d/etc/c/stlsoft/stlsoft.h
include/d/etc/c/stlsoft/stlsoft_cccap_dmc.h
include/d/etc/c/stlsoft/stlsoft_cccap_gcc.h
include/d/etc/c/stlsoft/stlsoft_iterator.h
@@ -61,104 +45,98 @@ include/d/etc/c/stlsoft/winstl_findfile_sequence.h
include/d/etc/c/stlsoft/winstl_spin_mutex.h
include/d/etc/c/stlsoft/winstl_system_version.h
include/d/etc/c/stlsoft/winstl_thread_mutex.h
-include/d/etc/c/stlsoft/stlsoft.h
-include/d/etc/c/zlib/zutil.h
-include/d/etc/c/zlib/algorithm.txt
-include/d/etc/c/zlib/ChangeLog
-include/d/etc/c/zlib/compress.c
-include/d/etc/c/zlib/crc32.c
+include/d/etc/c/stlsoft/winstl_tls_index.h
include/d/etc/c/zlib/crc32.h
-include/d/etc/c/zlib/deflate.c
include/d/etc/c/zlib/deflate.h
-include/d/etc/c/zlib/example.c
-include/d/etc/c/zlib/FAQ
-include/d/etc/c/zlib/gzio.c
-include/d/etc/c/zlib/INDEX
-include/d/etc/c/zlib/infback.c
-include/d/etc/c/zlib/infblock.c
include/d/etc/c/zlib/infblock.h
-include/d/etc/c/zlib/infcodes.c
include/d/etc/c/zlib/infcodes.h
-include/d/etc/c/zlib/inffast.c
include/d/etc/c/zlib/inffast.h
include/d/etc/c/zlib/inffixed.h
-include/d/etc/c/zlib/inflate.c
include/d/etc/c/zlib/inflate.h
-include/d/etc/c/zlib/inftrees.c
include/d/etc/c/zlib/inftrees.h
-include/d/etc/c/zlib/infutil.c
include/d/etc/c/zlib/infutil.h
-include/d/etc/c/zlib/linux.mak
-include/d/etc/c/zlib/maketree.c
-include/d/etc/c/zlib/minigzip.c
-include/d/etc/c/zlib/README
-include/d/etc/c/zlib/trees.c
include/d/etc/c/zlib/trees.h
-include/d/etc/c/zlib/uncompr.c
-include/d/etc/c/zlib/win32.mak
include/d/etc/c/zlib/zconf.h
include/d/etc/c/zlib/zconf.in.h
-include/d/etc/c/zlib/zlib.3
include/d/etc/c/zlib/zlib.h
-include/d/etc/c/zlib/zlib.html
-include/d/etc/c/zlib/zutil.c
-include/d/etc/c/zlib/adler32.c
-include/d/etc/c/zlib.d
-include/d/gcc/unwind.d
+include/d/etc/c/zlib/zutil.h
include/d/gcc/builtins.d
-include/d/gcc/cbridge_fdset.c
-include/d/gcc/cbridge_math.c
-include/d/gcc/cbridge_stdio.c
-include/d/gcc/cbridge_time.c
include/d/gcc/configext.d
include/d/gcc/deh.d
include/d/gcc/gcgcc.d
include/d/gcc/support.d
include/d/gcc/threadsem.d
-include/d/gcc/boehm-gc-d_init.c
+include/d/gcc/unwind.d
include/d/gcc/config.d
include/d/gcc/configunix.d
-include/d/internal/gc/win32.mak
-include/d/internal/gc/gcbits.d
-include/d/internal/gc/gclinux.d
-include/d/internal/gc/gcx.d
-include/d/internal/gc/linux.mak
-include/d/internal/gc/testgc.d
-include/d/internal/gc/win32.d
-include/d/internal/gc/gc.d
include/d/internal/aApply.d
+include/d/internal/aaA.d
include/d/internal/adi.d
include/d/internal/alloca.d
include/d/internal/arraycast.d
include/d/internal/arraycat.d
include/d/internal/cast.d
include/d/internal/cmath2.d
-include/d/internal/complex.c
-include/d/internal/critical.c
-include/d/internal/deh.c
include/d/internal/deh2.d
include/d/internal/dmain2.d
include/d/internal/invariant.d
include/d/internal/llmath.d
include/d/internal/mars.h
include/d/internal/memset.d
-include/d/internal/minit.asm
-include/d/internal/monitor.c
include/d/internal/obj.d
include/d/internal/object.d
include/d/internal/qsort.d
-include/d/internal/aaA.d
include/d/internal/switch.d
-include/d/std/windows/iunknown.d
-include/d/std/windows/registry.d
-include/d/std/c/mach/mach.d
-include/d/std/c/mach/mach_extern.d
-include/d/std/c/darwin/darwin.d
-include/d/std/c/linux/linux.d
-include/d/std/c/linux/linuxextern.d
-include/d/std/c/windows/com.d
-include/d/std/c/windows/windows.d
+include/d/internal/gc/gc.d
+include/d/internal/gc/gcbits.d
+include/d/internal/gc/gclinux.d
+include/d/internal/gc/gcx.d
+include/d/internal/gc/testgc.d
+include/d/internal/gc/win32.d
+include/d/std/array.d
+include/d/std/asserterror.d
+include/d/std/base64.d
+include/d/std/compiler.d
+include/d/std/conv.d
+include/d/std/ctype.d
+include/d/std/date.d
+include/d/std/dateparse.d
+include/d/std/file.d
+include/d/std/format.d
+include/d/std/gc.d
+include/d/std/intrinsic.d
+include/d/std/loader.d
+include/d/std/math.d
+include/d/std/math2.d
+include/d/std/md5.d
+include/d/std/mmfile.d
+include/d/std/moduleinit.d
+include/d/std/openrj.d
+include/d/std/outbuffer.d
+include/d/std/outofmemory.d
+include/d/std/path.d
+include/d/std/perf.d
+include/d/std/process.d
+include/d/std/random.d
+include/d/std/recls.d
+include/d/std/regexp.d
+include/d/std/socket.d
+include/d/std/socketstream.d
+include/d/std/stdarg.d
+include/d/std/stdint.d
+include/d/std/stdio.d
+include/d/std/stream.d
+include/d/std/string.d
+include/d/std/switcherr.d
+include/d/std/syserror.d
+include/d/std/system.d
+include/d/std/thread.d
+include/d/std/uri.d
+include/d/std/utf.d
+include/d/std/zip.d
+include/d/std/zlib.d
include/d/std/c/dirent.d
+include/d/std/c/math.d
include/d/std/c/process.d
include/d/std/c/stdarg.d
include/d/std/c/stddef.d
@@ -166,9 +144,15 @@ include/d/std/c/stdio.d
include/d/std/c/stdlib.d
include/d/std/c/time.d
include/d/std/c/unix.d
-include/d/std/c/math.d
-include/d/std/typeinfo/ti_wchar.d
+include/d/std/c/darwin/darwin.d
+include/d/std/c/linux/linux.d
+include/d/std/c/linux/linuxextern.d
+include/d/std/c/mach/mach.d
+include/d/std/c/mach/mach_extern.d
+include/d/std/c/windows/com.d
+include/d/std/c/windows/windows.d
include/d/std/typeinfo/ti_AC.d
+include/d/std/typeinfo/ti_Aa.d
include/d/std/typeinfo/ti_Adchar.d
include/d/std/typeinfo/ti_Ag.d
include/d/std/typeinfo/ti_Aint.d
@@ -179,9 +163,9 @@ include/d/std/typeinfo/ti_Auint.d
include/d/std/typeinfo/ti_Aulong.d
include/d/std/typeinfo/ti_Aushort.d
include/d/std/typeinfo/ti_Awchar.d
+include/d/std/typeinfo/ti_C.d
include/d/std/typeinfo/ti_bit.d
include/d/std/typeinfo/ti_byte.d
-include/d/std/typeinfo/ti_C.d
include/d/std/typeinfo/ti_cdouble.d
include/d/std/typeinfo/ti_cfloat.d
include/d/std/typeinfo/ti_char.d
@@ -202,66 +186,29 @@ include/d/std/typeinfo/ti_ubyte.d
include/d/std/typeinfo/ti_uint.d
include/d/std/typeinfo/ti_ulong.d
include/d/std/typeinfo/ti_ushort.d
-include/d/std/typeinfo/ti_Aa.d
-include/d/std/compiler.d
-include/d/std/conv.d
-include/d/std/ctype.d
-include/d/std/date.d
-include/d/std/dateparse.d
-include/d/std/file.d
-include/d/std/format.d
-include/d/std/gc.d
-include/d/std/intrinsic.d
-include/d/std/loader.d
-include/d/std/math.d
-include/d/std/math2.d
-include/d/std/md5.d
-include/d/std/mmfile.d
-include/d/std/moduleinit.d
-include/d/std/openrj.d
-include/d/std/outbuffer.d
-include/d/std/outofmemory.d
-include/d/std/path.d
-include/d/std/perf.d
-include/d/std/process.d
-include/d/std/random.d
-include/d/std/recls.d
-include/d/std/regexp.d
-include/d/std/stdio.d
-include/d/std/socket.d
-include/d/std/socketstream.d
-include/d/std/stdarg.d
-include/d/std/stdint.d
-include/d/std/stream.d
-include/d/std/string.d
-include/d/std/switcherr.d
-include/d/std/syserror.d
-include/d/std/system.d
-include/d/std/thread.d
-include/d/std/uri.d
-include/d/std/utf.d
-include/d/std/zip.d
-include/d/std/array.d
-include/d/std/zlib.d
-include/d/std/asserterror.d
-include/d/std/base64.d
+include/d/std/typeinfo/ti_wchar.d
+include/d/std/windows/iunknown.d
+include/d/std/windows/registry.d
+include/d/crc32.d
+include/d/gcstats.d
+include/d/object.d
include/d/phobos-ver-syms
-@dirrm include/d/etc/c/recls
-@dirrm include/d/etc/c/stlsoft
-@dirrm include/d/etc/c/zlib
-@dirrm include/d/etc/c
-@dirrm include/d/etc
-@dirrm include/d/gcc
-@dirrm include/d/internal/gc
-@dirrm include/d/internal
-@dirrm include/d/std/windows
-@dirrm include/d/std/c/mach
@dirrm include/d/std/c/darwin
@dirrm include/d/std/c/linux
+@dirrm include/d/std/c/mach
@dirrm include/d/std/c/windows
@dirrm include/d/std/c
@dirrm include/d/std/typeinfo
+@dirrm include/d/std/windows
@dirrm include/d/std
+@dirrm include/d/internal/gc
+@dirrm include/d/internal
+@dirrm include/d/gcc
+@dirrm include/d/etc/c/recls
+@dirrm include/d/etc/c/stlsoft
+@dirrm include/d/etc/c/zlib
+@dirrm include/d/etc/c
+@dirrm include/d/etc
@dirrm include/d/
lib/libphobos.a
lib/libphobos.spec