aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gdc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-01-06 15:24:08 +0800
committerrafan <rafan@FreeBSD.org>2007-01-06 15:24:08 +0800
commit6ac329d8184c9cb72a9197068748f1bc35ef175b (patch)
tree5827761aa2a18098868207e1df00793e3e938323 /lang/gdc
parent3a3d45576125d56e5bcef847260abd29a35ad303 (diff)
downloadfreebsd-ports-gnome-6ac329d8184c9cb72a9197068748f1bc35ef175b.tar.gz
freebsd-ports-gnome-6ac329d8184c9cb72a9197068748f1bc35ef175b.tar.zst
freebsd-ports-gnome-6ac329d8184c9cb72a9197068748f1bc35ef175b.zip
- Fix threading support, favor pthread
Since this port supports 5.x and later, we don't need to consider the 4.x case (-lc_r). Moreover, gdc uses ld as linker when compiling D source files, so PTHREAD_LIBS is not applicable here. PR: ports/107437 Submitted by: Jason DiCioccio <jd at ods.org> Approved by: Masanori OZAWA <ozawa at ongs.co.jp> (maintainer)
Diffstat (limited to 'lang/gdc')
-rw-r--r--lang/gdc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index 5e45ba5c9aee..e0b391a134d0 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdc
PORTVERSION= 0.19
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC} \
${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/dgcc/g:S/$/:gdc/g}
@@ -35,7 +35,8 @@ CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--disable-shared \
- --enable-languages=c,c++,d
+ --enable-languages=c,c++,d \
+ --enable-thread-lib=-lpthread
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}\///}/configure
PLIST_SUB= GCC_VER=${GCC_VERSION} CONF_TARGET=${CONFIGURE_TARGET}