aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gforth
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-30 00:09:58 +0800
committerjohans <johans@FreeBSD.org>2013-12-30 00:09:58 +0800
commitf8215386b8694d7293ac3e6abbf4f88aac1f1e5c (patch)
treedc6f5912eb4f19aaa34102d8d25374243fcd55ac /lang/gforth
parent864d6b29cd09b25e0ffa14219e50e66b2fcb0b73 (diff)
downloadfreebsd-ports-gnome-f8215386b8694d7293ac3e6abbf4f88aac1f1e5c.tar.gz
freebsd-ports-gnome-f8215386b8694d7293ac3e6abbf4f88aac1f1e5c.tar.zst
freebsd-ports-gnome-f8215386b8694d7293ac3e6abbf4f88aac1f1e5c.zip
Enable stage support
Diffstat (limited to 'lang/gforth')
-rw-r--r--lang/gforth/Makefile14
-rw-r--r--lang/gforth/pkg-plist16
2 files changed, 12 insertions, 18 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 7cde4158cdb6..c26d554cd152 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= http://www.complang.tuwien.ac.at/forth/gforth/ \
MAINTAINER= johans@FreeBSD.org
COMMENT= Fast and portable Forth system
-LIB_DEPENDS= ffi:${PORTSDIR}/devel/libffi
+LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
BUILD_DEPENDS= ${LOCALBASE}/include/avcall.h:${PORTSDIR}/devel/ffcall
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -fno-reorder-blocks -fno-inline
-USE_GMAKE= yes
+USES= gmake
USE_GCC= any
USE_AUTOTOOLS= libtool libltdl
USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
@@ -33,10 +33,8 @@ PORTDOCS= AUTHORS BUGS Benchres COPYING COPYING.DOC \
INSTALL INSTALL.BINDIST NEWS README \
NEWS.vmgen README.vmgen ToDo
-MAN1= gforth.1
INFO= gforth vmgen
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == i386 || ${ARCH} == powerpc
@@ -60,18 +58,18 @@ post-install: install-doc remove-empty-files remove-empty-dirs
install-doc:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
. for filename in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${filename} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${filename} ${STAGEDIR}${DOCSDIR}
. endfor
.endif
# Remove unused file
remove-empty-files:
- @${RM} -f ${DATADIR}/site-forth/siteinit.fs
+ @${RM} -f ${STAGEDIR}${DATADIR}/site-forth/siteinit.fs
# Remove unused directories
remove-empty-dirs:
- @${FIND} -d ${DATADIR}/${PORTVERSION}/arch/ -type d -empty -delete
+ @${FIND} -d ${STAGEDIR}${DATADIR}/${PORTVERSION}/arch/ -type d -empty -delete
.include <bsd.port.post.mk>
diff --git a/lang/gforth/pkg-plist b/lang/gforth/pkg-plist
index 3d6b18457bc7..21842e2f3893 100644
--- a/lang/gforth/pkg-plist
+++ b/lang/gforth/pkg-plist
@@ -1,18 +1,13 @@
bin/gforth-%%PORTVERSION%%
-@exec ln -fs %f %B/gforth
-@unexec rm -f %B/gforth
bin/gforth-fast-%%PORTVERSION%%
-@exec ln -fs %f %B/gforth-fast
-@unexec rm -f %B/gforth-fast
bin/gforth-itc-%%PORTVERSION%%
-@exec ln -fs %f %B/gforth-itc
-@unexec rm -f %B/gforth-itc
bin/gforthmi-%%PORTVERSION%%
-@exec ln -fs %f %B/gforthmi
-@unexec rm -f %B/gforthmi
bin/vmgen-%%PORTVERSION%%
-@exec ln -fs %f %B/vmgen
-@unexec rm -f %B/vmgen
+bin/gforth
+bin/gforth-fast
+bin/gforth-itc
+bin/gforthmi
+bin/vmgen
include/gforth/%%PORTVERSION%%/config.h
include/gforth/%%PORTVERSION%%/libcc.h
lib/gforth/%%PORTVERSION%%/gforth-ditc
@@ -33,6 +28,7 @@ lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.la
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.a
+man/man1/gforth.1.gz
%%DATADIR%%/%%PORTVERSION%%/TAGS
%%DATADIR%%/%%PORTVERSION%%/add.fs
%%DATADIR%%/%%PORTVERSION%%/ans-report.fs