aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2004-10-17 17:25:00 +0800
committerobraun <obraun@FreeBSD.org>2004-10-17 17:25:00 +0800
commitd1bc9823095e122ad20c4de834fe2602d92c08be (patch)
treee37d730516e23a1e23e2efbdb5cc37f0510987b6 /lang/ghc/Makefile
parentfe76d0dd19e528597405317073c04173515ff584 (diff)
downloadfreebsd-ports-gnome-d1bc9823095e122ad20c4de834fe2602d92c08be.tar.gz
freebsd-ports-gnome-d1bc9823095e122ad20c4de834fe2602d92c08be.tar.zst
freebsd-ports-gnome-d1bc9823095e122ad20c4de834fe2602d92c08be.zip
Upgrade ghc to 6.2.2, remove BROKEN, make portlint a little bit happier.
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index bf3154cb2ba5..ed7bb07f3ea0 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ghc
-PORTVERSION= 6.2.1
+PORTVERSION= 6.2.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
http://www.haskell.org/ghc/dist/${PORTVERSION}/FreeBSD/:boot
@@ -19,10 +19,6 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
@@ -41,7 +37,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_SUB= GHC_VERSION=${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
@@ -53,7 +49,7 @@ PLIST_SUB+= PROFILE=""
BOOT_DIR= ${WRKDIR}/ghc-${PORTVERSION}-boot
BOOT_GHC= ${BOOT_DIR}/bin/i386-unknown-freebsd/ghc-${PORTVERSION}
-CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
+CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
# specifying CONFIGURE_TARGET doesn't work for some reason.
CONFIGURE_TARGET=
# libgmp:
@@ -61,18 +57,18 @@ CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
# override TMPDIR because /tmp often doesn't have enough space
# to build some of the larger libraries.
-TMPDIR = ${WRKSRC}/tmp
-MAKE_ENV += TMPDIR=${TMPDIR}
+TMPDIR= ${WRKSRC}/tmp
+MAKE_ENV+= TMPDIR=${TMPDIR}
# Just do a stage1 build
-ALL_TARGET = stage1
+ALL_TARGET= stage1
MAKE_ENV += stage=1
pre-everything::
.if !defined(WITHOUT_PROFILE)
@${ECHO_CMD} "To build GHC without profiling libraries,"
@${ECHO_CMD} "hit Ctrl-C now and restart with 'make"
- @$(ECHO_CMD) "WITHOUT_PROFILE=YES'."
+ @${ECHO_CMD} "WITHOUT_PROFILE=YES'."
.else
@${ECHO_CMD} "Building GHC without profiling libraries."
.endif