aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-05-09 00:41:23 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-05-09 00:41:23 +0800
commite8a9705d90c0d83bb2cb05cf38a64f5e97a9a9b5 (patch)
tree4bbb89e343e38f48d2c7fe9257d6b8b381b917dc /lang/ghc/Makefile
parentb29dbadc264292422dda4831af7ead7854e0afa6 (diff)
downloadfreebsd-ports-gnome-e8a9705d90c0d83bb2cb05cf38a64f5e97a9a9b5.tar.gz
freebsd-ports-gnome-e8a9705d90c0d83bb2cb05cf38a64f5e97a9a9b5.tar.zst
freebsd-ports-gnome-e8a9705d90c0d83bb2cb05cf38a64f5e97a9a9b5.zip
Fix for -current
PR: 36803 Submitted by: maintainer
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index da1dac950e75..2b091500e006 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -11,12 +11,21 @@ MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/
SRC_DIST= ghc-${PORTVERSION}-src-1${EXTRACT_SUFX}
BOOT_DIST= ghc-${PORTVERSION}-i386-unknown-freebsd-boot${EXTRACT_SUFX}
+BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}
-DISTFILES= ${SRC_DIST} ${BOOT_DIST}
+USE_BZIP2= yes
+.include <bsd.port.pre.mk>
+
+DISTFILES= ${SRC_DIST}
+
+.if ${OSVERSION} < 500000
+DISTFILES+= ${BOOT_DIST}
+.else
+DISTFILES+= ${BOOT_DIST5}
+.endif
MAINTAINER= simonmar@microsoft.com
-USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -44,4 +53,4 @@ pre-configure:
pre-build:
@${MKDIR} ${TMPDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>