aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
committeredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
commitec40c1b18590a321d5dbd5ebbd73bea024902e87 (patch)
tree8e3df2c273b28d72e1077fa05e7244c8733a9f7a /lang/ghc/Makefile
parent7414fe7f0eb5384bcf0deaf5f4587f1c219c904e (diff)
downloadfreebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.gz
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.zst
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.zip
Remove always-false/true conditions based on OSVERSION 500000
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 8dc0584006f0..fda97792bf8e 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -36,20 +36,14 @@ OPTIONS= PROFILE "Compile for profiling as well" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-#DISTFILES+= ${BOOT_DIST4}
+.if ${OSVERSION} >= 700000
IGNORE= unsupported at the moment
-.else
-.if ${OSVERSION} >= 600000
+.elif ${OSVERSION} >= 600000
DISTFILES+= ${BOOT_DIST}
.else
IGNORE= unsupported at the moment
#DISTFILES+= ${BOOT_DIST5}
.endif
-.endif
-.if ${OSVERSION} >= 700000
-IGNORE= unsupported at the moment
-.endif
PLIST_SUB+= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)