aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc6-doc/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2004-01-16 06:25:50 +0800
committerolgeni <olgeni@FreeBSD.org>2004-01-16 06:25:50 +0800
commit9a9cbb1a757d966fe98469af58db7f298ca08916 (patch)
treeb0f6ae2ad0fa5e413863cadd21aa6b008c5fc082 /lang/ghc6-doc/Makefile
parent67de6dbc0830f1fa9536b93561b1bc18d11dae39 (diff)
downloadfreebsd-ports-gnome-9a9cbb1a757d966fe98469af58db7f298ca08916.tar.gz
freebsd-ports-gnome-9a9cbb1a757d966fe98469af58db7f298ca08916.tar.zst
freebsd-ports-gnome-9a9cbb1a757d966fe98469af58db7f298ca08916.zip
Upgrade to version 6.2. Add PORTVERSION to DIST_SUBDIR as the tarballs do
not have a version number. Also install under ${LOCALBASE}/share/doc/ghc6 to avoid conflicts with ghc-doc.
Diffstat (limited to 'lang/ghc6-doc/Makefile')
-rw-r--r--lang/ghc6-doc/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/ghc6-doc/Makefile b/lang/ghc6-doc/Makefile
index 878494d70859..0be09358e2ef 100644
--- a/lang/ghc6-doc/Makefile
+++ b/lang/ghc6-doc/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= ghc6-doc
-PORTVERSION= 6.0.1
+PORTVERSION= 6.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/docs/${PORTVERSION}/ \
http://www.haskell.org/ghc/docs/${PORTVERSION}/html/
DISTFILES= building.html.tar.gz building.ps.gz hslibs.html.tar.gz \
hslibs.ps.gz libraries.html.tar.gz users_guide.html.tar.gz \
users_guide.ps.gz index.html
-DIST_SUBDIR= ghc6
+DIST_SUBDIR= ghc-${PORTVERSION}
EXTRACT_ONLY=
MAINTAINER= olgeni@FreeBSD.org
@@ -22,15 +22,15 @@ COMMENT= Documentation (HTML, PS) for the Glasgow Haskell Compiler
NO_BUILD= yes
do-install:
- @${MKDIR} ${LOCALBASE}/share/doc/ghc
+ @${MKDIR} ${LOCALBASE}/share/doc/ghc6
.for FILE in building.ps.gz hslibs.ps.gz users_guide.ps.gz index.html
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${FILE} \
- ${LOCALBASE}/share/doc/ghc
+ ${LOCALBASE}/share/doc/ghc6
.endfor
.for FILE in building.html.tar.gz hslibs.html.tar.gz \
libraries.html.tar.gz users_guide.html.tar.gz
@${TAR} xfz ${DISTDIR}/${DIST_SUBDIR}/${FILE} \
- -C ${LOCALBASE}/share/doc/ghc
+ -C ${LOCALBASE}/share/doc/ghc6
.endfor
.include <bsd.port.mk>