aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-30 04:58:03 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-30 04:58:03 +0800
commitfdbc744a7fc199c99b23126afbc734c6c83245b2 (patch)
tree839dae9fb41b0159dbb24d75dc16efbcf3872e05 /lang/ghc
parent45cea88c17cb66e0a2e389f0e95e37507d23c47d (diff)
downloadfreebsd-ports-gnome-fdbc744a7fc199c99b23126afbc734c6c83245b2.tar.gz
freebsd-ports-gnome-fdbc744a7fc199c99b23126afbc734c6c83245b2.tar.zst
freebsd-ports-gnome-fdbc744a7fc199c99b23126afbc734c6c83245b2.zip
Move the USE_PERL definitions, and others, before pre.mk inclusion. This
will be needed to conditionalize bsd.perl.mk inclusion. Approved by: maintainer
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 104c1c48e637..ec53ae67f256 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -24,7 +24,13 @@ BOOT_DIST4= ghc-${PORTVERSION}-i386-unknown-freebsd4-boot${EXTRACT_SUFX}:boot
BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
BOOT_DIST= ghc-${PORTVERSION}-i386-unknown-freebsd6-boot${EXTRACT_SUFX}:boot
+USE_AUTOTOOLS= autoconf:259:env
USE_BZIP2= yes
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_PERL5= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
OPTIONS= PROFILE "Compile for profiling as well" on
@@ -45,13 +51,6 @@ IGNORE= unsupported at the moment
IGNORE= unsupported at the moment
.endif
-USE_AUTOTOOLS= autoconf:259:env
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-
-USE_PERL5= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
PLIST_SUB+= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "