aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gjs
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /lang/gjs
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'lang/gjs')
-rw-r--r--lang/gjs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/gjs/Makefile b/lang/gjs/Makefile
index 17ab7460c983..26829de2311f 100644
--- a/lang/gjs/Makefile
+++ b/lang/gjs/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gjs
PORTVERSION= 1.34.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -17,7 +17,7 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
CONFLICTS_BUILD=spidermonkey17-1.7.*
-USES= gettext gmake libtool pathfix pkgconfig shebangfix tar:xz
+USES= gettext gmake libtool:keepla pathfix pkgconfig shebangfix tar:xz
USE_PYTHON_BUILD=2
USE_GNOME= cairo glib20 gnomeprefix introspection:build intlhack
USE_LDCONFIG= yes