aboutsummaryrefslogtreecommitdiffstats
path: root/lang/glibstdc++28
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-11-11 00:33:08 +0800
committerobrien <obrien@FreeBSD.org>1998-11-11 00:33:08 +0800
commit15b94dcfbffdec8c9c0b31bb664ede90ad2cd74a (patch)
tree1395311f1799bf9e57b9353aee81424269fe2a3f /lang/glibstdc++28
parentd0853504e183e7e6b3df3aaa420c39e941eabdca (diff)
downloadfreebsd-ports-gnome-15b94dcfbffdec8c9c0b31bb664ede90ad2cd74a.tar.gz
freebsd-ports-gnome-15b94dcfbffdec8c9c0b31bb664ede90ad2cd74a.tar.zst
freebsd-ports-gnome-15b94dcfbffdec8c9c0b31bb664ede90ad2cd74a.zip
fix for 3.0 ELF
Submitted by: Alec Wolman <wolman@cs.washington.edu>
Diffstat (limited to 'lang/glibstdc++28')
-rw-r--r--lang/glibstdc++28/Makefile17
-rw-r--r--lang/glibstdc++28/pkg-descr2
-rw-r--r--lang/glibstdc++28/pkg-plist4
3 files changed, 14 insertions, 9 deletions
diff --git a/lang/glibstdc++28/Makefile b/lang/glibstdc++28/Makefile
index f8d08ff80d64..684ab0f0ee09 100644
--- a/lang/glibstdc++28/Makefile
+++ b/lang/glibstdc++28/Makefile
@@ -1,10 +1,10 @@
# ex:ts=8
# Ports collection makefile for: GNU libstdc++
-# Version required: 2.8.0
+# Version required: 2.8.1.1
# Date created: 03 Mar 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id: Makefile,v 1.10 1998/08/17 17:03:31 obrien Exp $
+# $Id: Makefile,v 1.11 1998/10/12 15:04:35 jseger Exp $
#
DISTNAME= libstdc++-2.8.1.1
@@ -21,12 +21,17 @@ RUN_DEPENDS= gcc28:${PORTSDIR}/lang/gcc28 \
CC= gcc28
CXX= g++28
-GCC28DIR= lib/gcc-lib/i386-unknown-freebsd${OSREL}/2.8.1
+ARE_WE_ELF!= text -x /usr/bin/objformat && /usr/bin/objformat || echo aout
+.if ${ARE_WE_ELF} == "elf"
+GNUHOST= i386-unknown-freebsdelf${OSREL}
+.else
+GNUHOST= i386-unknown-freebsd${OSREL}
+.endif
+GCC28DIR= lib/gcc-lib/${GNUHOST}/2.8.1
+CONFIGURE_ARGS= --host=${GNUHOST}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-PLIST_SUB= GCC28SUBDIR=${GCC28DIR}
-
-BROKEN_ELF= depends on gcc28
+PLIST_SUB= GCC28SUBDIR=${GCC28DIR} GNUHOST=${GNUHOST}
pre-install:
@# allow a boched ``make install'' to be re-tried
diff --git a/lang/glibstdc++28/pkg-descr b/lang/glibstdc++28/pkg-descr
index 2f738591c1f1..02838b07dd86 100644
--- a/lang/glibstdc++28/pkg-descr
+++ b/lang/glibstdc++28/pkg-descr
@@ -1,4 +1,4 @@
-This is the ISO Standard C++ library (includes the STL) for G++ 2.8.0,
+This is the ISO Standard C++ library (includes the STL) for G++ 2.8.x,
the latest release of the GNU C++ compiler suite.
It is a port for now, until its stableness is proven.
diff --git a/lang/glibstdc++28/pkg-plist b/lang/glibstdc++28/pkg-plist
index 929054ed4a41..062170cfb387 100644
--- a/lang/glibstdc++28/pkg-plist
+++ b/lang/glibstdc++28/pkg-plist
@@ -136,7 +136,7 @@
%%GCC28SUBDIR%%/include/g++/tree.h
%%GCC28SUBDIR%%/include/g++/type_traits.h
%%GCC28SUBDIR%%/include/g++/vector.h
-i386-unknown-freebsd%%OSREL%%/include/_G_config.h
-i386-unknown-freebsd%%OSREL%%/lib/libiberty.a
+%%GNUHOST%%/include/_G_config.h
+%%GNUHOST%%/lib/libiberty.a
@dirrm %%GCC28SUBDIR%%/include/g++/std
@dirrm %%GCC28SUBDIR%%/include/g++