aboutsummaryrefslogtreecommitdiffstats
path: root/lang/glibstdc++28
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /lang/glibstdc++28
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'lang/glibstdc++28')
-rw-r--r--lang/glibstdc++28/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/glibstdc++28/Makefile b/lang/glibstdc++28/Makefile
index 684ab0f0ee09..44f36d31a778 100644
--- a/lang/glibstdc++28/Makefile
+++ b/lang/glibstdc++28/Makefile
@@ -4,7 +4,7 @@
# Date created: 03 Mar 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id: Makefile,v 1.11 1998/10/12 15:04:35 jseger Exp $
+# $Id: Makefile,v 1.12 1998/11/10 16:33:07 obrien Exp $
#
DISTNAME= libstdc++-2.8.1.1
@@ -19,10 +19,11 @@ BUILD_DEPENDS= gcc28:${PORTSDIR}/lang/gcc28 \
RUN_DEPENDS= gcc28:${PORTSDIR}/lang/gcc28 \
g++28:${PORTSDIR}/lang/gcc28
+.include <bsd.port.pre.mk>
+
CC= gcc28
CXX= g++28
-ARE_WE_ELF!= text -x /usr/bin/objformat && /usr/bin/objformat || echo aout
-.if ${ARE_WE_ELF} == "elf"
+.if ${PORTOBJFORMAT} == "elf"
GNUHOST= i386-unknown-freebsdelf${OSREL}
.else
GNUHOST= i386-unknown-freebsd${OSREL}
@@ -49,4 +50,4 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/osfcn.h \
${PREFIX}/${GCC28DIR}/include/g++
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>