aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnat/Makefile
diff options
context:
space:
mode:
authordas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
committerdas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
commitd0a8169f66cd61514add7ee911c6b6db0e51c1b9 (patch)
tree2f20a76d035a3b6d76643819e4d11cd7456ce538 /lang/gnat/Makefile
parentffbef27bb1180c2cd5cf7122154e05f714d21605 (diff)
downloadfreebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.gz
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.zst
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.zip
Fix build. Ports that formerly attempted to work around problems
created by matherr() no longer need to do so.
Diffstat (limited to 'lang/gnat/Makefile')
-rw-r--r--lang/gnat/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index acba2c2fbc04..83d0792a5a38 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -1,3 +1,4 @@
+
# New ports collection makefile for: GNU Ada gnat
# Date created: Sat Mar 18 02:16:45 1995
# Whom: hsu
@@ -37,6 +38,9 @@ GCC_VERSION= 2.8.1
PLIST_SUB= GNUHOST=${GNUHOST} GCC_VERSION=${GCC_VERSION} \
LIBRARY_VERSION=${LIBRARY_VERSION} \
SHARED_MAJOR=${SHARED_MAJOR}
+.if ${OSVERSION} < 600011
+PLIST_FILES+= lib/gcc-lib/${GNUHOST}/${GCC_VERSION}/include/math.h
+.endif
# Make no mistake about what host/target we are building on/for.
# This package does not support cross-compiling, and this fixes