aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnustep-objc/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-04-13 19:23:43 +0800
committerdinoex <dinoex@FreeBSD.org>2004-04-13 19:23:43 +0800
commit0d02f3c279d9da75e0963689c48081d934929fd4 (patch)
tree05232d3a4c843add505ec1d976362a9d3b270528 /lang/gnustep-objc/Makefile
parent928cd5933e615c4cfc84d33926ba0f9d52ed5300 (diff)
downloadfreebsd-ports-gnome-0d02f3c279d9da75e0963689c48081d934929fd4.tar.gz
freebsd-ports-gnome-0d02f3c279d9da75e0963689c48081d934929fd4.tar.zst
freebsd-ports-gnome-0d02f3c279d9da75e0963689c48081d934929fd4.zip
- resurrect from 2003/03/02
- update to 1.3.0 - new gnustep paths - use bsd.gnustep.mk to build - bump PORTEPOCH
Diffstat (limited to 'lang/gnustep-objc/Makefile')
-rw-r--r--lang/gnustep-objc/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index 8e1c973e8a97..a2fd1e82a3d5 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -1,30 +1,30 @@
-# New ports collection makefile for: gnustep-objc
-# Date created: 28.Mar.2003
-# Whom: dirk.meyer@dinoex.sub.org
+# New ports collection makefile for: gnustep-objc
+# Date created: 17 April 2001
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
-CATEGORIES= lang
-PKGNAMESUFFIX= -objc
+PORTNAME= gnustep-objc
+PORTVERSION= 1.3.0
+PORTEPOCH= 1
+CATEGORIES= lang devel
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= libs
MAINTAINER= dinoex@FreeBSD.org
-COMMENT= GNU Compiler Collection 3.2.3 with threads and shared libs
+COMMENT= A snapshot of libobjc, meant to be used with GNUstep
-WANT_SHAREDLIBS= yes
-WANT_THREADS_SUPPORT= yes
-MASTERDIR?= ${.CURDIR}/../../lang/gcc32
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
-LDFLAGS+= -L${LOCALBASE}/lib
+PREFIX= ${LOCALBASE}/GNUstep
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+GNUSTEP_WITHOUT_LIBOBJC= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+INSTALLS_SHLIB= yes
+NOT_FOR_ARCHS= ia64
-# does not build on:
-NOT_FOR_ARCHS= amd64
-
-CONFLICTS?= gcc-3.2*
-
-.if exists(${.CURDIR}/Makefile.local)
-.include "${.CURDIR}/Makefile.local"
-.endif
-
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>