aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnustep-objc/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-08-29 00:58:27 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-08-29 00:58:27 +0800
commita295d1348bea4520f81bd151c3bc02dd148250af (patch)
treee8b90d7255d09d81648d80bbe5262a212e596510 /lang/gnustep-objc/Makefile
parentdc17a362cf32861497624a9b58d8730de223b5ee (diff)
downloadfreebsd-ports-gnome-a295d1348bea4520f81bd151c3bc02dd148250af.tar.gz
freebsd-ports-gnome-a295d1348bea4520f81bd151c3bc02dd148250af.tar.zst
freebsd-ports-gnome-a295d1348bea4520f81bd151c3bc02dd148250af.zip
Make this port a little more sane. It was broken
for any system that wasn't x86 on freebsd 3.1. The port is still marked BROKEN because it sets PREFIX in the Makefile. PR: 13423 Submitted by: Ade Lovett <ade@lovett.com>
Diffstat (limited to 'lang/gnustep-objc/Makefile')
-rw-r--r--lang/gnustep-objc/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index e2e198afe3cd..3825abbddac3 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -17,13 +17,21 @@ MAINTAINER= ports@FreeBSD.ORG
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff34
+BROKEN= "Sets PREFIX in the Makefile"
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 300000
BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.endif
-BROKEN= "Hardcoded freebsd release numbers in PLIST"
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+GNU_HOST= freebsd${OSREL}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} GNU_HOST=${GNU_HOST}
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
@@ -41,14 +49,4 @@ MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
USE_NEWGCC= yes
-GNUSTEPLIBDIR= ${PREFIX}/Libraries/ix86/freebsd3.1/gnu-gnu-gnu-xraw
-
-post-install:
-.for lib in gmodel gnustep-base gnustep-gui gnustep-xraw
- ${LN} -sf ${GNUSTEPLIBDIR}/lib${lib}.so ${LOCALBASE}/lib/lib${lib}.so
- ${LN} -sf ${GNUSTEPLIBDIR}/lib${lib}.so.0.5.5 \
- ${LOCALBASE}/lib/lib${lib}.so.0.5.5
-.endfor
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${LOCALBASE}/lib
-
.include <bsd.port.post.mk>