aboutsummaryrefslogtreecommitdiffstats
path: root/lang/go
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-01 22:08:37 +0800
committermat <mat@FreeBSD.org>2016-04-01 22:08:37 +0800
commit0e1e582c065e8fdcb4c8070ec1b22a3d70aa3a7c (patch)
tree23607acdfffe977946d3c7bb877bab60e64640e7 /lang/go
parent148314483d3098c0d6a33944f1190842e671502f (diff)
downloadfreebsd-ports-gnome-0e1e582c065e8fdcb4c8070ec1b22a3d70aa3a7c.tar.gz
freebsd-ports-gnome-0e1e582c065e8fdcb4c8070ec1b22a3d70aa3a7c.tar.zst
freebsd-ports-gnome-0e1e582c065e8fdcb4c8070ec1b22a3d70aa3a7c.zip
Remove ${PORTSDIR}/ from dependencies, categories h, i, j, k, and l.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'lang/go')
-rw-r--r--lang/go/Makefile2
-rw-r--r--lang/go/files/bsd.go.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/go/Makefile b/lang/go/Makefile
index d6eef451ae41..a408b15ead10 100644
--- a/lang/go/Makefile
+++ b/lang/go/Makefile
@@ -13,7 +13,7 @@ COMMENT= Go programming language
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= go14>=1.4:${PORTSDIR}/lang/go14
+BUILD_DEPENDS= go14>=1.4:lang/go14
USES= shebangfix
SHEBANG_LANG= sh
diff --git a/lang/go/files/bsd.go.mk b/lang/go/files/bsd.go.mk
index 03302c7d3d8c..384225e8121e 100644
--- a/lang/go/files/bsd.go.mk
+++ b/lang/go/files/bsd.go.mk
@@ -41,7 +41,7 @@ GO_WRKDIR_BIN= ${WRKDIR}/bin
GO_WRKDIR_SRC= ${WRKDIR}/src
GO_WRKDIR_PKG= ${WRKDIR}/pkg/${OPSYS:tl}_${GOARCH}
-BUILD_DEPENDS+= ${GO_CMD}:${PORTSDIR}/lang/go
+BUILD_DEPENDS+= ${GO_CMD}:lang/go
GO_ENV+= GOPATH="${WRKDIR}:${LOCAL_GOPATH}" \
CGO_CFLAGS="${CGO_CFLAGS}" \
CGO_LDFLAGS="${CGO_LDFLAGS}" \