aboutsummaryrefslogtreecommitdiffstats
path: root/lang/guile/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-04 12:55:14 +0800
committermarcus <marcus@FreeBSD.org>2003-04-04 12:55:14 +0800
commitb642429d876c2647c4b7e57f236f9478e04c506d (patch)
treebf3c3b113eb31ede81c2c08d3fd55dd8bd66352b /lang/guile/files
parentb16097f6fbab192e5ba337888427c7bd0ffcf5da (diff)
downloadfreebsd-ports-gnome-b642429d876c2647c4b7e57f236f9478e04c506d.tar.gz
freebsd-ports-gnome-b642429d876c2647c4b7e57f236f9478e04c506d.tar.zst
freebsd-ports-gnome-b642429d876c2647c4b7e57f236f9478e04c506d.zip
Work around what I believe to be a broken implementation of isfinite()
in -CURRENT that was causing a numerical overflow in apps such as GnuCash. PR: 50089
Diffstat (limited to 'lang/guile/files')
-rw-r--r--lang/guile/files/patch-libguile_numbers.c22
1 files changed, 22 insertions, 0 deletions
diff --git a/lang/guile/files/patch-libguile_numbers.c b/lang/guile/files/patch-libguile_numbers.c
new file mode 100644
index 000000000000..2ba35040ab81
--- /dev/null
+++ b/lang/guile/files/patch-libguile_numbers.c
@@ -0,0 +1,22 @@
+--- libguile/numbers.c.orig Thu Apr 3 23:52:25 2003
++++ libguile/numbers.c Thu Apr 3 23:52:41 2003
+@@ -89,8 +89,8 @@
+ /* Return true if X is not infinite and is not a NaN
+ Dirk:FIXME:: Since IS_INF is broken, this test does not work if x == 0
+ */
+-#ifndef isfinite
+-#define isfinite(x) (!IS_INF (x) && (x) == (x))
++#ifndef xxx_isfinite
++#define xxx_isfinite(x) (!IS_INF (x) && (x) == (x))
+ #endif
+
+
+@@ -4071,7 +4071,7 @@
+ if (SCM_FIXABLE (lu)) {
+ return SCM_MAKINUM (lu);
+ #ifdef SCM_BIGDIG
+- } else if (isfinite (u)) {
++ } else if (xxx_isfinite (u)) {
+ return scm_dbl2big (u);
+ #endif
+ } else {
-1/+31 * Switch to use daemon(8) in rc script to avoid keeping a tty open.ale2010-09-302-3/+3 * Add missing closing quotes.ale2010-08-241-1/+1 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * Update to 5.0.90 release.ale2010-02-162-4/+4 * As announced, remove MySQL 6.0 (dead development branch) and update CONFLICTS.ale2010-01-111-3/+3 * Update to 5.0.89 release.ale2009-12-293-31/+4 * Update to 5.0.88 release.ale2009-11-212-4/+4 * Update to 5.0.87 release.ale2009-10-262-4/+4 * Update to 5.0.86 release:ale2009-09-243-5/+23 * Update to 5.0.85 release.ale2009-08-272-4/+4 * Update to 5.0.84 release and use bundled libtool.ale2009-07-243-21/+7 * Update CONFLICTS.ale2009-07-211-3/+3 * Update to 5.0.83 release.ale2009-06-122-4/+4 * Update to 5.0.82 release and add additional manpages.ale2009-06-082-11/+23 * Update to 5.0.81 release.ale2009-05-133-8/+8 * - Mark MAKE_JOBS_SAFE for SMP compilationmm2009-03-251-0/+1 * Add mysqld embedded server library and fix pkg-plist.ale2009-03-043-3/+28 * Update to 5.0.77 release.ale2009-02-172-5/+4 * Move the USE_PERL5 definition for the scripts slave ports from the masterlinimon2009-01-171-1/+0 * Update to 5.0.75 release.ale2008-12-293-18/+5 * Accept all linuxthreads library major versions.ale2008-11-171-1/+1 * - Fix client input validation vulnerabilityale2008-10-113-2/+29 * Update to 5.0.67 release.ale2008-08-276-93/+24 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-211-1/+0 * Make startup script ssh-friendly.ale2008-07-301-1/+1 * Update CONFLICTS and remove duplicated USE_PERL5.ale2008-07-261-3/+3 * Update to 5.0.51a release.ale2008-02-013-4/+16 * Fix SSL connections.ale2008-01-211-0/+57 * Backport a couple of small enhancement from mysql 5.1 port.ale2007-12-122-0/+37 * Update to 5.0.51 release.ale2007-12-125-126/+6 * - tmpdir fix [1]ale2007-10-083-1/+128 * Update to 5.0.45 release.ale2007-07-125-18/+19 * Update to 5.0.41 release and drop support for FreeBSD < 5.ale2007-05-205-47/+25 * Fix previouos commit.ale2007-04-181-1/+1 * Use the new @stopdaemon feature.ale2007-04-181-1/+1 * Update to 5.0.37 release.ale2007-03-154-16/+5 * Update to 5.0.33 release.ale2007-01-274-26/+17 * Fix dependencies.ale2007-01-201-1/+1 * - Update to 5.0.27. Fix ABI incompatibility.mnag2006-10-302-4/+4 * Update to 5.0.26 release and fix two security vulnerabilitiesale2006-10-225-22/+14 * - Apply fix to ulong problem. http://bugs.mysql.com/bug.php?id=22227mnag2006-09-272-1/+22 * - Update to 5.0.24a releaseale2006-09-072-4/+8 * - Fix build with OpenSSLpav2006-08-101-10/+21 * - Update to 5.0.24pav2006-08-076-21/+13 * Remove the temporary hack to use the new USE_LDCONFIG feature.ale2006-06-221-5/+0 * - Update to 5.0.22mnag2006-06-022-4/+4 * Remove USE_REINPLACE from all categories starting with Dedwin2006-05-051-1/+0 * Update to 5.0.21 release.ale2006-05-033-4/+7 * Update to 5.0.20 release.ale2006-04-102-4/+4 * Update to 5.0.19 release:ale2006-03-175-14/+25 * Fix rcNG startup ordering for MySQL daemon.ale2006-03-082-3/+2 * Conversion to a single libtool environment.ade2006-02-232-1/+4 * Update CONFLICTS after MySQL 5.1 import.ale2006-02-051-4/+4 * Add zlib to plist if FreeBSD < 5.0ale2006-01-292-0/+9 * Replace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-221-3/+3 * Fix build on 4.X (use included zlib on 4.X).ale2006-01-111-2/+2 * Update to 5.0.18 release:ale2006-01-094-27/+9 * Update to 5.0.17 release.ale2005-12-23