aboutsummaryrefslogtreecommitdiffstats
path: root/lang/guile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-02-05 14:10:54 +0800
committermarcus <marcus@FreeBSD.org>2003-02-05 14:10:54 +0800
commit45d744b1c6487790537216d0ba640c1f97941cb9 (patch)
tree218f99252465be923b51255183223890197cb2cf /lang/guile
parent0b3b6985ae1061c6d3c4c31385d44a0307842640 (diff)
downloadfreebsd-ports-gnome-45d744b1c6487790537216d0ba640c1f97941cb9.tar.gz
freebsd-ports-gnome-45d744b1c6487790537216d0ba640c1f97941cb9.tar.zst
freebsd-ports-gnome-45d744b1c6487790537216d0ba640c1f97941cb9.zip
* Teach guile about LOCALBASE and X11BASE when looking for scheme modules
* Assign maintainership to gnome
Diffstat (limited to 'lang/guile')
-rw-r--r--lang/guile/Makefile6
-rw-r--r--lang/guile/files/patch-libguile_load.c11
2 files changed, 15 insertions, 2 deletions
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index b30cdb5e987f..3cdb354e9a90 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -7,12 +7,12 @@
PORTNAME= guile
PORTVERSION= 1.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= guile
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
@@ -35,5 +35,7 @@ post-extract:
post-patch:
cd ${WRKSRC} ; \
${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' ${REINPLACE_FILES}
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%LOCALBASE|${LOCALBASE}|g' ${WRKSRC}/libguile/load.c
.include <bsd.port.mk>
diff --git a/lang/guile/files/patch-libguile_load.c b/lang/guile/files/patch-libguile_load.c
new file mode 100644
index 000000000000..6cc5eb43b0b6
--- /dev/null
+++ b/lang/guile/files/patch-libguile_load.c
@@ -0,0 +1,11 @@
+--- libguile/load.c.orig Tue Feb 4 21:05:24 2003
++++ libguile/load.c Tue Feb 4 21:19:39 2003
+@@ -239,6 +239,8 @@
+ path = scm_listify (scm_makfrom0str (SCM_SITE_DIR),
+ scm_makfrom0str (SCM_LIBRARY_DIR),
+ scm_makfrom0str (SCM_PKGDATA_DIR),
++ scm_makfrom0str ("%%X11BASE%%/share/guile"),
++ scm_makfrom0str ("%%LOCALBASE%%/share/guile"),
+ SCM_UNDEFINED);
+ #endif /* SCM_LIBRARY_DIR */
+