aboutsummaryrefslogtreecommitdiffstats
path: root/lang/icc
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2002-04-01 03:00:05 +0800
committernetchild <netchild@FreeBSD.org>2002-04-01 03:00:05 +0800
commitdb995df1708eacbb965f6ee73c20d5b51e206800 (patch)
tree79c6b3248e07bbcefa1f4b52059234cb61af3521 /lang/icc
parent41a15ede524bb9ac38f2193a02b9b3d951e9d0e0 (diff)
downloadfreebsd-ports-gnome-db995df1708eacbb965f6ee73c20d5b51e206800.tar.gz
freebsd-ports-gnome-db995df1708eacbb965f6ee73c20d5b51e206800.tar.zst
freebsd-ports-gnome-db995df1708eacbb965f6ee73c20d5b51e206800.zip
- reword pkg-descr
- fix iccvars.csh (PR) - mimic some parts of gcc's preprocessor (defines) PR: 36555 Approved by: steve
Diffstat (limited to 'lang/icc')
-rw-r--r--lang/icc/Makefile22
-rw-r--r--lang/icc/files/patch-iccvars.csh16
-rw-r--r--lang/icc/pkg-descr4
3 files changed, 31 insertions, 11 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 857b7cee8002..097056d6a138 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 5.0.1
+PORTREVISION= 1
CATEGORIES= lang linux
MASTER_SITES= http://www.intel.com/software/products/compilers/c50/linux/
DISTNAME= cc010911rh71
@@ -31,6 +32,8 @@ NO_CDROM= yes
.include <bsd.port.pre.mk>
+ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= "Please manually download the version for RedHat 7.1 from ${MASTER_SITES}, put it into ${DISTDIR} and run make again"
.endif
@@ -51,15 +54,6 @@ pre-patch:
xargs -0 ${CHMOD} a-x,g-w
.endfor
@${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
-.for i in ia32/bin/iccvars.csh ia32/bin/iccvars.sh ia32/bin/icc.cfg \
- ia32/bin/icpc.cfg docs/iccsupport
- @${SED} 's@\<INSTALLDIR\>@${PREFIX}/intel@g' \
- ${WRKSRC}/opt/intel/compiler50/${i} \
- >${WRKSRC}/opt/intel/compiler50/${i}.seded
- @${MV} -f ${WRKSRC}/opt/intel/compiler50/${i}.seded \
- ${WRKSRC}/opt/intel/compiler50/${i}
- @${CHMOD} 755 ${WRKSRC}/opt/intel/compiler50/${i}
-.endfor
.for i in icc iccfilt icid icpc icpi mcpcom profmerge proforder
@brandelf -t Linux ${WRKSRC}/opt/intel/compiler50/ia32/bin/${i}
.endfor
@@ -68,10 +62,20 @@ pre-patch:
.endfor
post-patch:
+.for i in ia32/bin/iccvars.csh ia32/bin/iccvars.sh ia32/bin/icc.cfg \
+ ia32/bin/icpc.cfg docs/iccsupport
+ @${SED} 's@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@' \
+ ${WRKSRC}/opt/intel/compiler50/${i} \
+ >${WRKSRC}/opt/intel/compiler50/${i}.seded
+ @${MV} -f ${WRKSRC}/opt/intel/compiler50/${i}.seded \
+ ${WRKSRC}/opt/intel/compiler50/${i}
+ @${CHMOD} 755 ${WRKSRC}/opt/intel/compiler50/${i}
+.endfor
@${RM} ${WRKSRC}/opt/intel/compiler50/ia32/include/yvals.h.orig
.if defined(NOPORTDOCS)
@${RM} -rf ${WRKSRC}/opt/intel/compiler50/docs
.endif
+ @${ECHO} -e "\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/compiler50/ia32/bin/icc.cfg
do-install:
@cd ${WRKSRC}/opt && ${TAR} -chf - . | \
diff --git a/lang/icc/files/patch-iccvars.csh b/lang/icc/files/patch-iccvars.csh
new file mode 100644
index 000000000000..3f3e6906f747
--- /dev/null
+++ b/lang/icc/files/patch-iccvars.csh
@@ -0,0 +1,16 @@
+--- opt/intel/compiler50/ia32/bin/iccvars.csh.orig Sun Mar 31 11:14:54 2002
++++ opt/intel/compiler50/ia32/bin/iccvars.csh Sun Mar 31 11:16:11 2002
+@@ -1,4 +1,4 @@
+-#! /bin/tcsh
++#! /bin/csh
+ if ! ($?IA32ROOT) then
+ setenv IA32_SAVE_PATH $PATH
+ if ($?LD_LIBRARY_PATH) then
+@@ -24,6 +24,6 @@
+ setenv LD_LIBRARY_PATH $IA32ROOT/lib:$IA32_SAVE_LD_LIBRARY_PATH
+ endif
+
+-setenv INTEL_FLEXLM_LICENSE=<INSTALLDIR>/licenses
++setenv INTEL_FLEXLM_LICENSE <INSTALLDIR>/licenses
+
+
diff --git a/lang/icc/pkg-descr b/lang/icc/pkg-descr
index 1b668787fdd6..601a1ca57758 100644
--- a/lang/icc/pkg-descr
+++ b/lang/icc/pkg-descr
@@ -1,5 +1,5 @@
This is Intels C/C++ compiler, it is set up so produce native FreeBSD objects.
-This port is not able to produce native executables on its own, you need to do
-it yourself with gcc.
+This port is not able to produce native executables on its own, you need to
+use gcc to link the final binary.
WWW: http://www.intel.com/software/products/compilers/c50/linux