aboutsummaryrefslogtreecommitdiffstats
path: root/lang/icc
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-02-19 05:21:49 +0800
committernetchild <netchild@FreeBSD.org>2005-02-19 05:21:49 +0800
commitd1250180a3f0f00c608b48a173fdc08fe7256ab3 (patch)
treed7f9affc3fa222a1eba71f6668160b4c70131298 /lang/icc
parent532d2549ebc41259bf1703858622967871336f0e (diff)
downloadfreebsd-ports-gnome-d1250180a3f0f00c608b48a173fdc08fe7256ab3.tar.gz
freebsd-ports-gnome-d1250180a3f0f00c608b48a173fdc08fe7256ab3.tar.zst
freebsd-ports-gnome-d1250180a3f0f00c608b48a173fdc08fe7256ab3.zip
The static linking case (C++ only) expects a crtbeginT.o. Based upon
inspection of src/contrib/gnu/crtstuff.c it seems it's the same as crtbegin.o, so make a symlink for it. At least linking a "Hello World" program with -static produces a working executable now. Noticed by: Niklas Sorensson <nik@cs.chalmers.se>
Diffstat (limited to 'lang/icc')
-rw-r--r--lang/icc/Makefile5
-rw-r--r--lang/icc/pkg-plist1
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index cd7b248eb23f..7fade79427e7 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icc
PORTVERSION= 8.1.026
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION:C/p.+$//}
@@ -219,6 +219,9 @@ do-build:
.for file in crtbegin.o crtend.o libgcc.a
@cd ${WRKSRC}/opt/${COMPILERDIR}/lib && ${LN} -s /usr/lib/${file} ${file}
.endfor
+# The static linking case expects a crtbeginT.o. Based upon inspection of
+# /usr/src/contrib/gnu/crtstuff.c it seems it's the same as crtbegin.o.
+ @cd ${WRKSRC}/opt/${COMPILERDIR}/lib && ${LN} -s crtbegin.o crtbeginT.o
do-install:
@cd ${WRKSRC}/opt && ${FIND} . -print | \
diff --git a/lang/icc/pkg-plist b/lang/icc/pkg-plist
index fa00166b5340..b546ebf53b6b 100644
--- a/lang/icc/pkg-plist
+++ b/lang/icc/pkg-plist
@@ -930,6 +930,7 @@
%%COMPILERDIR%%/include/xmmintrin.h
@dirrm %%COMPILERDIR%%/include
%%COMPILERDIR%%/lib/crtbegin.o
+%%COMPILERDIR%%/lib/crtbeginT.o
%%COMPILERDIR%%/lib/crtend.o
%%COMPILERDIR%%/lib/crtxi.o
%%COMPILERDIR%%/lib/crtxn.o