aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ifc/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-10-08 08:04:36 +0800
committermaho <maho@FreeBSD.org>2003-10-08 08:04:36 +0800
commit74102d2bba9d80e9d265e32d57116acf1bd66fc9 (patch)
treed5923f675da7b60079dbd9852a80a9b0ce914e07 /lang/ifc/Makefile
parent2e013489f7b039783e8bc56bed8e96544221d07d (diff)
downloadfreebsd-ports-gnome-74102d2bba9d80e9d265e32d57116acf1bd66fc9.tar.gz
freebsd-ports-gnome-74102d2bba9d80e9d265e32d57116acf1bd66fc9.tar.zst
freebsd-ports-gnome-74102d2bba9d80e9d265e32d57116acf1bd66fc9.zip
IFC fails to link when invoked with -ax or -x option
because a static library of ifc has an unresolved symbol, __sigsetjmp. The following is an example of error messages: PR: 57574 Submitted by: Masakazu HIGAKI <higamasa@dream.com>
Diffstat (limited to 'lang/ifc/Makefile')
-rw-r--r--lang/ifc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index f70f070dafa3..4e2dc6c9077b 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -122,7 +122,8 @@ do-build:
.for i in libcxa.a libimf.a libirc.a libircmt.a libunwind.a \
libBINDF90.a libCEPCF90.a libF90.a libIEPCF90.a libPEPCF90.a \
libcprts.a libintrins.a libompstub.a
- @${OBJCOPY} --redefine-sym stdin=__stdinp \
+ @${OBJCOPY} --redefine-sym __sigsetjmp=sigsetjmp \
+ --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/lib/${i}