aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ifc7
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
commit0a792d129c721bbf05ec4507020041dae7ccb939 (patch)
tree5443a6df79f666d3a39d8c4f9b5f89991dc6ce44 /lang/ifc7
parent0bfadbd86b2e8399c2d3221e66321fc0dc66cab1 (diff)
downloadfreebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.tar.gz
freebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.tar.zst
freebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'lang/ifc7')
-rw-r--r--lang/ifc7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index d78eabe30757..22ac742f92ea 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -77,9 +77,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
# Use the Linux ABI for the binaries
.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}