aboutsummaryrefslogtreecommitdiffstats
path: root/lang/io/Makefile
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2017-09-13 19:46:23 +0800
committergahr <gahr@FreeBSD.org>2017-09-13 19:46:23 +0800
commit1d17c8d29dff9a6ca7c9a2cd3aab0caea27cd7de (patch)
tree5496be1e466cc4ba30241faef5518f847aeeccb5 /lang/io/Makefile
parentc0c14ba7388e15e1ed31ed0b842068b9abcd05bd (diff)
downloadfreebsd-ports-gnome-1d17c8d29dff9a6ca7c9a2cd3aab0caea27cd7de.tar.gz
freebsd-ports-gnome-1d17c8d29dff9a6ca7c9a2cd3aab0caea27cd7de.tar.zst
freebsd-ports-gnome-1d17c8d29dff9a6ca7c9a2cd3aab0caea27cd7de.zip
lang/io: update to 2017.09.06
Diffstat (limited to 'lang/io/Makefile')
-rw-r--r--lang/io/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index 4ee60e78bd43..9e332eb656bd 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= io
-PORTVERSION= 2015.11.11
-PORTREVISION= 7
+PORTVERSION= 2017.09.06
CATEGORIES= lang
MAINTAINER= gahr@FreeBSD.org
@@ -13,11 +12,11 @@ LICENSE= BSD3CLAUSE
BROKEN_armv6= fails to compile: ucontext.h: expected parameter declarator
+USES= cmake:outsource,noninja compiler:c11 ssl
+
USE_GITHUB= yes
GH_ACCOUNT= stevedekorte
-GH_TAGNAME= 23afbcc
-USES= cmake:outsource,noninja compiler:c11
MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
@@ -48,4 +47,8 @@ post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+do-test:
+ cd ${BUILD_WRKSRC} && \
+ ./_build/binaries/io ${WRKSRC}/libs/iovm/tests/correctness/run.io
+
.include <bsd.port.mk>