aboutsummaryrefslogtreecommitdiffstats
path: root/lang/itcl/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-05-18 04:35:55 +0800
committermi <mi@FreeBSD.org>2006-05-18 04:35:55 +0800
commitb9f0c543e1db30cae3093cea664570b01fde7b9a (patch)
tree601e79761f507d27e857cf7475319c2c882a9197 /lang/itcl/Makefile
parentcd19e45b413aeb1b942bc925a1164c3562809b39 (diff)
downloadfreebsd-ports-gnome-b9f0c543e1db30cae3093cea664570b01fde7b9a.tar.gz
freebsd-ports-gnome-b9f0c543e1db30cae3093cea664570b01fde7b9a.tar.zst
freebsd-ports-gnome-b9f0c543e1db30cae3093cea664570b01fde7b9a.zip
Update the itcl/itk from 3.2 to 3.3 (released in April 2005). The
installed libraries are now named libitcl.so.3 & libitk.so.3 instead of having the version be part of the libname (libitcl33.so.1). The itclConfig.sh and itkConfig.sh are now also installed, which is required by some software (such as the insight -- a gdb frontend). Fix-up the (unchanged) iwidgets port to reflect the above and improve it to not require its own copy of the itcl tree at install time. Approved by: maintainer Fix-up the tkdesk port to reflect the itcl/itk changes, which required updating it to the 2.0p2 (from 2.0). (This lovely piece of software badly needs a caring maintainer, BTW.) While here, teach tkdesk to use installed blt instead of building its own. The only iwidget/itk/itcl consumer that remains broken is net/smm++ (a MUD client). This should change as soon as the maintainer get back to me.
Diffstat (limited to 'lang/itcl/Makefile')
-rw-r--r--lang/itcl/Makefile32
1 files changed, 10 insertions, 22 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 14701e24b128..79d6f7882229 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -6,60 +6,48 @@
#
PORTNAME= itcl
-PORTVERSION= ${MAJOR}.${MINOR}.1
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= lang tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=incrtcl
DISTNAME= itcl${PORTVERSION}
-EXTRACT_SUFX= _src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= [incr Tcl] (A.K.A. "itcl")
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84
-WRKSRC= ${WRKDIR}/${DISTNAME}/itcl
INSTALLS_SHLIB= yes
PKGINSTALL= ${PORTSDIR}/lang/tcl84/pkg-install.tclsh
PKGDEINSTALL= ${PORTSDIR}/lang/tcl84/pkg-deinstall.tclsh
MAKE_ENV+= ${PLIST_SUB} \
SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - itcl${PORTVERSION}/itcl
-
.if defined(MAKE_JOBS)
MAKE_ARGS+= -j${MAKE_JOBS}
.endif
-SHLIB_MAJOR= 1
-SHLIB_MINOR= 1
-MAJOR= 3
-MINOR= 2
+SHLIB_MAJOR= ${MAJOR}
+SHLIB_MINOR= ${MINOR}
+MAJOR= ${PORTVERSION:R}
+MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
-ITCL_LIB= libitcl${MAJOR}${MINOR}.so
+ITCL_LIB= libitcl.so
MAKEFILE= ${FILESDIR}/Makefile.lib
MANCOMPRESSED= no
MANN= body.n class.n code.n configbody.n delete.n ensemble.n find.n
-MANN+= itcl.n itcl_class.n itcl_info.n itclvars.n local.n scope.n
+MANN+= is.n itcl.n itclvars.n local.n scope.n
+MAN3= RegisterC.3 Stack.3
ITCL_LIB_FILE= ${ITCL_LIB}.${SHLIB_MAJOR}
-post-patch:
- ${REINPLACE_CMD} \
- -e 's,package require Itcl,load [glob \
- ${WRKSRC}/${ITCL_LIB}.${SHLIB_MAJOR}*],;' \
- ${WRKSRC}/tests/*.test
-
post-build test:
cd ${WRKSRC} && ${SETENV} ITCL_LIBRARY=${WRKSRC}/library \
- ${PREFIX}/bin/tclsh8.4 tests/all.tcl
+ ${PREFIX}/bin/tclsh8.4 tests/all.tcl -load "load ./${ITCL_LIB}"
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.n ${PREFIX}/man/mann/
-.if exists(${PKGINSTALL})
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.3 ${PREFIX}/man/man3/
.include <bsd.port.mk>