aboutsummaryrefslogtreecommitdiffstats
path: root/lang/itcl/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-05 19:13:24 +0800
committerpav <pav@FreeBSD.org>2003-12-05 19:13:24 +0800
commit662a1b0ba653dd9c27a57539088f52cb720196f3 (patch)
tree21738a1d9111d4e42c8048155b3c0b3e728f69e5 /lang/itcl/Makefile
parentcffca0065ae3211b9cf1183db1f25aa491135fd1 (diff)
downloadfreebsd-ports-gnome-662a1b0ba653dd9c27a57539088f52cb720196f3.tar.gz
freebsd-ports-gnome-662a1b0ba653dd9c27a57539088f52cb720196f3.tar.zst
freebsd-ports-gnome-662a1b0ba653dd9c27a57539088f52cb720196f3.zip
- Update to work with tcl8.4
- Quiet portlint a bit PR: ports/58466 Submitted by: Michael Edenfield <kutulu@kutulu.org>
Diffstat (limited to 'lang/itcl/Makefile')
-rw-r--r--lang/itcl/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index e0b2f02d2329..dc8a6ab2bee5 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= itcl
PORTVERSION= ${MAJOR}.${MINOR}
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=incrtcl
@@ -15,20 +16,20 @@ DISTNAME= itcl${PORTVERSION}
MAINTAINER= ports@freebsd.org
COMMENT= [incr Tcl] (A.K.A. "itcl")
-LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84
WRKSRC= ${WRKDIR}/${DISTNAME}/itcl
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-PKGINSTALL= ${PORTSDIR}/lang/tcl83/pkg-install.tclsh
-PKGDEINSTALL= ${PORTSDIR}/lang/tcl83/pkg-deinstall.tclsh
+PKGINSTALL= ${PORTSDIR}/lang/tcl84/pkg-install.tclsh
+PKGDEINSTALL= ${PORTSDIR}/lang/tcl84/pkg-deinstall.tclsh
MAKE_ENV+= ${PLIST_SUB} \
SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - ./itcl${MAJOR}.${MINOR}/itcl
.if defined(MAKE_JOBS)
-MAKE_ARGS+= -j$(MAKE_JOBS)
+MAKE_ARGS+= -j${MAKE_JOBS}
.endif
SHLIB_MAJOR= 1
@@ -56,7 +57,7 @@ post-patch:
post-build test:
cd ${WRKSRC} && ${SETENV} ITCL_LIBRARY=${WRKSRC}/library \
- ${PREFIX}/bin/tclsh8.3 tests/all.tcl
+ ${PREFIX}/bin/tclsh8.4 tests/all.tcl
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.n ${PREFIX}/man/mann/