aboutsummaryrefslogtreecommitdiffstats
path: root/lang/jruby/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:24:09 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:24:09 +0800
commitf6e00c6523a54ccae8d9221d4c43c1bebbe1592d (patch)
tree31ce147ffecf3f2de724e507ca8926196bdc04cd /lang/jruby/Makefile
parent2a436f8061602989d2bc9da2badeb810b25743fe (diff)
downloadfreebsd-ports-gnome-f6e00c6523a54ccae8d9221d4c43c1bebbe1592d.tar.gz
freebsd-ports-gnome-f6e00c6523a54ccae8d9221d4c43c1bebbe1592d.tar.zst
freebsd-ports-gnome-f6e00c6523a54ccae8d9221d4c43c1bebbe1592d.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'lang/jruby/Makefile')
-rw-r--r--lang/jruby/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/jruby/Makefile b/lang/jruby/Makefile
index 88cd473c1241..729710a8d7d5 100644
--- a/lang/jruby/Makefile
+++ b/lang/jruby/Makefile
@@ -33,8 +33,8 @@ post-extract:
do-build:
( \
- ${ECHO} '#!/bin/sh'; \
- ${ECHO} 'exec ${JAVA} -jar ${PREFIX}/share/java/classes/jruby.jar "$$@"'; \
+ ${ECHO_CMD} '#!/bin/sh'; \
+ ${ECHO_CMD} 'exec ${JAVA} -jar ${PREFIX}/share/java/classes/jruby.jar "$$@"'; \
) > ${WRKSRC}/jruby
do-install:
@@ -50,8 +50,8 @@ post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC}; find ${FILES} -type f | sort | ${SED} 's,^,share/java/${PORTNAME}/,' >> ${TMPPLIST}
cd ${WRKSRC}; find ${FILES} -type d | sort -r | ${SED} 's,^,@dirrm share/java/${PORTNAME}/,' >> ${TMPPLIST}
- ${ECHO} '@dirrm share/java/${PORTNAME}' >> ${TMPPLIST}
+ ${ECHO_CMD} '@dirrm share/java/${PORTNAME}' >> ${TMPPLIST}
.endif
- ${ECHO} '@unexec ${RMDIR} %D/share/java 2> /dev/null || true' >> ${TMPPLIST}
+ ${ECHO_CMD} '@unexec ${RMDIR} %D/share/java 2> /dev/null || true' >> ${TMPPLIST}
.include <bsd.port.mk>