aboutsummaryrefslogtreecommitdiffstats
path: root/lang/kturtle
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
commit18f8d6818a2205ed543432ae7b736e36bb0b1ab5 (patch)
treea38d8a80d7330fafe33e6504e265797c7db5c8ee /lang/kturtle
parent7e1a35526ca99e8f9cc466c562f4184911eb911c (diff)
downloadfreebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.gz
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.zst
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'lang/kturtle')
-rw-r--r--lang/kturtle/Makefile27
-rw-r--r--lang/kturtle/distinfo2
-rw-r--r--lang/kturtle/pkg-descr17
-rw-r--r--lang/kturtle/pkg-plist23
4 files changed, 69 insertions, 0 deletions
diff --git a/lang/kturtle/Makefile b/lang/kturtle/Makefile
new file mode 100644
index 000000000000..1fe30398c7ea
--- /dev/null
+++ b/lang/kturtle/Makefile
@@ -0,0 +1,27 @@
+# New ports collection Makefile for: kturtle
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kturtle
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= lang kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Educational programming environment for KDE 4
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/lang/kturtle/distinfo b/lang/kturtle/distinfo
new file mode 100644
index 000000000000..77bd2dbe298b
--- /dev/null
+++ b/lang/kturtle/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/kturtle-4.7.2.tar.bz2) = 0a29fd66443c1332978ade3fa9f384e5635f8d1e508b7a3d483a44cf7ff00ca2
+SIZE (KDE/kturtle-4.7.2.tar.bz2) = 227232
diff --git a/lang/kturtle/pkg-descr b/lang/kturtle/pkg-descr
new file mode 100644
index 000000000000..eb1c114f5db0
--- /dev/null
+++ b/lang/kturtle/pkg-descr
@@ -0,0 +1,17 @@
+KTurtle is an educational programming environment for KDE. KTurtle
+aims to make programming as easy and touchable as possible, and
+therefore can be used to teach kids the basics of math, geometry
+and... programming.
+
+The programming language used in KTurtle is loosely based on Logo.
+KTurtle allows, just like some implementations of Logo, to translate
+the programming language (the commands, the documentation and the
+error messages) to the native language of the programmer. Translating
+the programming language to the native language of the programmer is
+one of the many ways KTurtle tries to make learning to programming
+more simple. Other features to help to achieve this goal are:
+intuitive syntax highlighting, simple error messages, integrated
+canvas to make drawings on, integrated help function, slow-motion or
+step execution, and more.
+
+WWW: http://edu.kde.org/kturtle
diff --git a/lang/kturtle/pkg-plist b/lang/kturtle/pkg-plist
new file mode 100644
index 000000000000..3be396bda3f3
--- /dev/null
+++ b/lang/kturtle/pkg-plist
@@ -0,0 +1,23 @@
+bin/kturtle
+share/applications/kde4/kturtle.desktop
+share/apps/kturtle/kturtleui.rc
+share/config/kturtle.knsrc
+share/doc/HTML/en/kturtle/common
+share/doc/HTML/en/kturtle/getting-started.docbook
+share/doc/HTML/en/kturtle/glossary.docbook
+share/doc/HTML/en/kturtle/index.cache.bz2
+share/doc/HTML/en/kturtle/index.docbook
+share/doc/HTML/en/kturtle/mainwindow.png
+share/doc/HTML/en/kturtle/mainwindow_flower_nrs.png
+share/doc/HTML/en/kturtle/programming-reference.docbook
+share/doc/HTML/en/kturtle/translator-guide.docbook
+share/doc/HTML/en/kturtle/using-kturtle.docbook
+share/icons/hicolor/128x128/apps/kturtle.png
+share/icons/hicolor/16x16/apps/kturtle.png
+share/icons/hicolor/22x22/apps/kturtle.png
+share/icons/hicolor/32x32/apps/kturtle.png
+share/icons/hicolor/48x48/apps/kturtle.png
+share/icons/hicolor/64x64/apps/kturtle.png
+share/icons/hicolor/scalable/apps/kturtle.svgz
+@dirrm share/doc/HTML/en/kturtle
+@dirrm share/apps/kturtle