aboutsummaryrefslogtreecommitdiffstats
path: root/lang/librep
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /lang/librep
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'lang/librep')
-rw-r--r--lang/librep/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index ef0b9c5114ab..0cd9dcd8c82b 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -26,7 +26,6 @@ USE_GNOME= gnomehack
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-aclocaldir=${PREFIX}/share/aclocal \
--with-stack-direction=-1
USE_LDCONFIG= yes
@@ -35,8 +34,8 @@ MANCOMPRESSED= yes
MAN1= rep.1 rep-remote.1 rep-xgettext.1 repdoc.1
INFO= librep
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>