aboutsummaryrefslogtreecommitdiffstats
path: root/lang/linux-hla/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-31 03:23:38 +0800
committermiwi <miwi@FreeBSD.org>2006-12-31 03:23:38 +0800
commit3c7b516d88496b013fea493d016bf853120750c9 (patch)
treedff1b40aa556a88a2dcd1c291f8ecb981c81dae4 /lang/linux-hla/Makefile
parent123197788a33b1b8eea934b456de9147518ae0cf (diff)
downloadfreebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.tar.gz
freebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.tar.zst
freebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.zip
This is the port of Randall Hyde's High Level Assembly (HLA).
Don't let the name fool you. HLA is "real" assembly language, just made easier for beginners so they can learn the language faster than ever before. Anything you can do with a traditional assembler can be done with HLA; HLA just happens to do a lot more than traditional assemblers! WWW: http://webster.cs.ucr.edu/ PR: ports/107224 Submitted by: Hernan Di Pietro <hernan.di.pietro at gmail.com>
Diffstat (limited to 'lang/linux-hla/Makefile')
-rw-r--r--lang/linux-hla/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/lang/linux-hla/Makefile b/lang/linux-hla/Makefile
new file mode 100644
index 000000000000..c57f55220f49
--- /dev/null
+++ b/lang/linux-hla/Makefile
@@ -0,0 +1,42 @@
+# ports collection makefile for: linux-hla
+# Date created: 26 December 2006
+# Whom: Hernan Di Pietro <hernan.di.pietro@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hla
+PORTVERSION= 1.86
+CATEGORIES= lang
+MASTER_SITES= http://webster.cs.ucr.edu/AsmTools/HLA/HLAv${PORTVERSION}/
+PKGNAMEPREFIX= linux-
+DISTNAME= hla
+
+MAINTAINER= hernan.di.pietro@gmail.com
+COMMENT= Randall Hyde High-Level Assembly (HLA) port
+
+IA32_BINARY_PORT= yes
+USE_LINUX= yes
+NO_INSTALL_MANPAGES= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hla ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hlaparse ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/include/hla
+ ${MKDIR} ${PREFIX}/lib/hla
+ ${INSTALL_DATA} ${WRKSRC}/hlalib/hlalib.a ${PREFIX}/lib/hla
+ ${MKDIR} ${PREFIX}/include/hla/os
+ ${INSTALL_DATA} ${WRKSRC}/include/*.hhf ${PREFIX}/include/hla
+ ${INSTALL_DATA} ${WRKSRC}/include/*.scc ${PREFIX}/include/hla
+ ${INSTALL_DATA} ${WRKSRC}/include/os/*.hhf ${PREFIX}/include/hla/os
+ ${INSTALL_DATA} ${WRKSRC}/include/os/*.scc ${PREFIX}/include/hla/os
+
+post-install:
+ ${BRANDELF} -t Linux ${PREFIX}/bin/hla
+ ${BRANDELF} -t Linux ${PREFIX}/bin/hlaparse
+
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>