aboutsummaryrefslogtreecommitdiffstats
path: root/lang/malbolge/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-06-15 01:13:19 +0800
committermarkp <markp@FreeBSD.org>2001-06-15 01:13:19 +0800
commitf8b0094ee4f3d0824ee47da62a6f549747d3c318 (patch)
tree5493aa288fd3a3fa1581e44b8fb10a19fc0b831d /lang/malbolge/Makefile
parent57c53c466c4596bf13b6c269ff1028e2c2211cdc (diff)
downloadfreebsd-ports-gnome-f8b0094ee4f3d0824ee47da62a6f549747d3c318.tar.gz
freebsd-ports-gnome-f8b0094ee4f3d0824ee47da62a6f549747d3c318.tar.zst
freebsd-ports-gnome-f8b0094ee4f3d0824ee47da62a6f549747d3c318.zip
Add malbolge 1.0, an Infernal programming language.
Cleaned up before commit. PR: 28147 Submitted by: simond@irrelevant.org
Diffstat (limited to 'lang/malbolge/Makefile')
-rw-r--r--lang/malbolge/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/malbolge/Makefile b/lang/malbolge/Makefile
new file mode 100644
index 000000000000..675c15c52164
--- /dev/null
+++ b/lang/malbolge/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: malbolge
+# Date created: 14 June 2001
+# Whom: simond@irrelevant.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= malbolge
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://www.mines.edu/students/b/bolmstea/malbolge/
+DISTNAME= malbolge
+
+MAINTAINER= simond@irrelevant.org
+
+post-patch:
+ ${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g" ${WRKSRC}/malbolge.c
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/malbolge.c -o ${WRKSRC}/malbolge
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/malbolge ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${WRKSRC}/nop.mal \
+ ${PREFIX}/share/doc/malbolge
+.endif
+
+.include <bsd.port.mk>