aboutsummaryrefslogtreecommitdiffstats
path: root/lang/modula-3-socks/Makefile
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>1996-11-01 10:37:35 +0800
committerjdp <jdp@FreeBSD.org>1996-11-01 10:37:35 +0800
commitcc0a779e9a2548a146eef59e528387cf5cfb457b (patch)
tree872518e47aa52008beb19bf127c36b78405b65db /lang/modula-3-socks/Makefile
parentec7d2f089bc5add0ccc9ee96bfb0a9640476d517 (diff)
downloadfreebsd-ports-gnome-cc0a779e9a2548a146eef59e528387cf5cfb457b.tar.gz
freebsd-ports-gnome-cc0a779e9a2548a146eef59e528387cf5cfb457b.tar.zst
freebsd-ports-gnome-cc0a779e9a2548a146eef59e528387cf5cfb457b.zip
This package implements SOCKS support for Modula-3 applications. It
will be used to support SOCKS operation in the soon-to-be-released next version of CVSup. A tip of the hat to: Darryl Okahata, who developed the patches necessary to make the SOCKS library work with Modula-3's multithreaded I/O system.
Diffstat (limited to 'lang/modula-3-socks/Makefile')
-rw-r--r--lang/modula-3-socks/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/lang/modula-3-socks/Makefile b/lang/modula-3-socks/Makefile
new file mode 100644
index 000000000000..f8ee0777fce4
--- /dev/null
+++ b/lang/modula-3-socks/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: modula-3-socks
+# Version required: A.B9.06
+# Date created: 31 Oct 1996
+# Whom: John Polstra <jdp@polstra.com>
+#
+# $Id$
+#
+
+DISTNAME= modula-3-socks
+PKGNAME= modula-3-socks-1.0
+CATEGORIES+= lang
+MASTER_SITES= ftp://ftp.cup.hp.com/dist/socks/A.B9.06/
+DISTFILES= socks.tar.gz
+
+MAINTAINER= jdp@polstra.com
+
+NO_WRKSUBDIR= yes
+
+libm3socks_files= accept.c bind.c close.c connect.c dup.c dup2.c \
+ gethostbyaddr.c gethostbyname.c getpeername.c \
+ getsockname.c listen.c read.c recv.c recvfrom.c \
+ select.c send.c sendto.c shutdown.c socket.c \
+ socksconf.h wrap.h write.c
+
+m3socks_files= m3socks.sh m3socks.1 m3socks.conf.5
+
+post-extract:
+ @cp -p ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
+ @test -d ${WRKSRC}/libm3socks || mkdir ${WRKSRC}/libm3socks
+ @cd ${FILESDIR}; \
+ cp -p Makefile.libm3socks ${WRKSRC}/libm3socks/Makefile; \
+ cp -p ${libm3socks_files} ${WRKSRC}/libm3socks
+ @test -d ${WRKSRC}/m3socks || mkdir ${WRKSRC}/m3socks
+ @cd ${FILESDIR}; \
+ cp -p Makefile.m3socks ${WRKSRC}/m3socks/Makefile; \
+ cp -p ${m3socks_files} ${WRKSRC}/m3socks
+
+pre-install:
+ @cd ${PREFIX}/lib; \
+ test -d m3/FreeBSD2 || { \
+ mkdir -p m3/FreeBSD2; \
+ chown ${BINOWN}.${BINGRP} m3 m3/FreeBSD2; \
+ }
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/m3socks.conf ]; then \
+ echo -n "Please create a configuration file in "; \
+ echo "${PREFIX}/etc/m3socks.conf"; \
+ echo "Read m3socks.conf(5) for details"; \
+ fi
+
+.include <bsd.port.mk>