aboutsummaryrefslogtreecommitdiffstats
path: root/lang/modula-3-socks
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1996-11-12 10:19:40 +0800
committerobrien <obrien@FreeBSD.org>1996-11-12 10:19:40 +0800
commit99df43bf1336afac77ff9926acf7893da84f2186 (patch)
tree9999e9819d03eba09ced920e326c13b87718436c /lang/modula-3-socks
parent5c40e6d58c96aabdf311daa6728225174bf63001 (diff)
downloadfreebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.tar.gz
freebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.tar.zst
freebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.zip
CATAGORIES+= -> CATAGORIES=
Reordered vars where needed. Added MAINTAINERS where needed, many mkdir --> ${MKDIR}, install -> ${INSTALL_*}, etc.
Diffstat (limited to 'lang/modula-3-socks')
-rw-r--r--lang/modula-3-socks/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/lang/modula-3-socks/Makefile b/lang/modula-3-socks/Makefile
index f8ee0777fce4..f67f65db4bac 100644
--- a/lang/modula-3-socks/Makefile
+++ b/lang/modula-3-socks/Makefile
@@ -3,12 +3,12 @@
# Date created: 31 Oct 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1996/11/01 02:37:33 jdp Exp $
#
DISTNAME= modula-3-socks
PKGNAME= modula-3-socks-1.0
-CATEGORIES+= lang
+CATEGORIES= lang
MASTER_SITES= ftp://ftp.cup.hp.com/dist/socks/A.B9.06/
DISTFILES= socks.tar.gz
@@ -25,20 +25,20 @@ libm3socks_files= accept.c bind.c close.c connect.c dup.c dup2.c \
m3socks_files= m3socks.sh m3socks.1 m3socks.conf.5
post-extract:
- @cp -p ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
- @test -d ${WRKSRC}/libm3socks || mkdir ${WRKSRC}/libm3socks
+ @${CP} -p ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
+ @test -d ${WRKSRC}/libm3socks || ${MKDIR} ${WRKSRC}/libm3socks
@cd ${FILESDIR}; \
- cp -p Makefile.libm3socks ${WRKSRC}/libm3socks/Makefile; \
- cp -p ${libm3socks_files} ${WRKSRC}/libm3socks
- @test -d ${WRKSRC}/m3socks || mkdir ${WRKSRC}/m3socks
+ ${CP} -p Makefile.libm3socks ${WRKSRC}/libm3socks/Makefile; \
+ ${CP} -p ${libm3socks_files} ${WRKSRC}/libm3socks
+ @test -d ${WRKSRC}/m3socks || ${MKDIR} ${WRKSRC}/m3socks
@cd ${FILESDIR}; \
- cp -p Makefile.m3socks ${WRKSRC}/m3socks/Makefile; \
- cp -p ${m3socks_files} ${WRKSRC}/m3socks
+ ${CP} -p Makefile.m3socks ${WRKSRC}/m3socks/Makefile; \
+ ${CP} -p ${m3socks_files} ${WRKSRC}/m3socks
pre-install:
@cd ${PREFIX}/lib; \
test -d m3/FreeBSD2 || { \
- mkdir -p m3/FreeBSD2; \
+ ${MKDIR} m3/FreeBSD2; \
chown ${BINOWN}.${BINGRP} m3 m3/FreeBSD2; \
}