aboutsummaryrefslogtreecommitdiffstats
path: root/lang/mono/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-15 00:09:07 +0800
committermarino <marino@FreeBSD.org>2014-03-15 00:09:07 +0800
commit0750797720702e06934b6982d82f2984c1f81164 (patch)
treeaf495ced2efa453380fec2ceb1a869b97843b720 /lang/mono/Makefile
parentb6cf6af17eccc55baf4e7692222170205352cbcf (diff)
downloadfreebsd-ports-gnome-0750797720702e06934b6982d82f2984c1f81164.tar.gz
freebsd-ports-gnome-0750797720702e06934b6982d82f2984c1f81164.tar.zst
freebsd-ports-gnome-0750797720702e06934b6982d82f2984c1f81164.zip
lang/mono: Unbreak configure/runaway
Mono was set to build via clang unconditionally. Other than have a large, unnecessary dependency on clang33, this didn't bother DragonFly until recently. The 3.2.8 version has a conftest to test for a working __thread implementation (which DragonFly has), but for some reason the test locks up when built by clang. I built the conftest manually with gcc and it returned fine. In any case, DragonFly's gcc47 base compiler builds mono fine, so to unbreak the port on DragonFly, only specify clang on FreeBSD.
Diffstat (limited to 'lang/mono/Makefile')
-rw-r--r--lang/mono/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 3b3daa7d8b73..3489599439ca 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -42,6 +42,7 @@ ONLY_FOR_ARCHS= i386 amd64 powerpc
# Base GCC used to cause problems, so compile using clang which is usualy in
# base. However, the clang version shipped with some older FreeBSD version will
# not compile Mono, in such a case, compile using a clang port.
+.if ${OPSYS} == FreeBSD
.if ${OSVERSION} >= 902001 && exists(/usr/bin/clang)
CC= /usr/bin/clang
CXX= /usr/bin/clang++
@@ -52,6 +53,7 @@ CC= clang33
CXX= clang33
CPP= clang-cpp33
.endif
+.endif
pre-everything::
@${CAT} ${PKGMESSAGE}