aboutsummaryrefslogtreecommitdiffstats
path: root/lang/moscow_ml
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1996-11-12 10:19:40 +0800
committerobrien <obrien@FreeBSD.org>1996-11-12 10:19:40 +0800
commit99df43bf1336afac77ff9926acf7893da84f2186 (patch)
tree9999e9819d03eba09ced920e326c13b87718436c /lang/moscow_ml
parent5c40e6d58c96aabdf311daa6728225174bf63001 (diff)
downloadfreebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.tar.gz
freebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.tar.zst
freebsd-ports-gnome-99df43bf1336afac77ff9926acf7893da84f2186.zip
CATAGORIES+= -> CATAGORIES=
Reordered vars where needed. Added MAINTAINERS where needed, many mkdir --> ${MKDIR}, install -> ${INSTALL_*}, etc.
Diffstat (limited to 'lang/moscow_ml')
-rw-r--r--lang/moscow_ml/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 468643fe7210..4b6d5e13ea27 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -3,12 +3,12 @@
# Date created: 26 July 1996
# Whom: chuckr
#
-# $Id: Makefile,v 1.4 1996/07/30 01:24:55 chuckr Exp $
+# $Id: Makefile,v 1.5 1996/10/11 18:58:01 asami Exp $
#
DISTNAME= mos14src
PKGNAME= moscow_ml-1.4
-CATEGORIES+= lang
+CATEGORIES= lang
MASTER_SITES= ftp://ftp.dina.kvl.dk/pub/mosml/ \
ftp://ftp.csd.uu.se/pub/mirror/mosml/ \
ftp://ftp.dcs.ed.ac.uk/pub/ml/Moscow/
@@ -20,14 +20,14 @@ WRKSRC= ${WRKDIR}/mosml/src
post-install:
.if !defined(NOPORTDOCS)
- mkdir -p ${PREFIX}/moscow_ml/doc
- mkdir -p ${PREFIX}/moscow_ml/examples
+ ${MKDIR} ${PREFIX}/moscow_ml/doc
+ ${MKDIR} ${PREFIX}/moscow_ml/examples
for file in ${WRKDIR}/mosml/doc/*;do \
${INSTALL_DATA} $${file} ${PREFIX}/moscow_ml/doc;done
(cd ${WRKDIR}/mosml/examples; \
${INSTALL_DATA} README ${PREFIX}/moscow_ml/examples; \
for sdirs in manual mls helpsigs calc pretty lexyacc;do \
- mkdir -p ${PREFIX}/moscow_ml/examples/$${sdirs}; \
+ ${MKDRI} ${PREFIX}/moscow_ml/examples/$${sdirs}; \
for file in $${sdirs}/*;do \
${INSTALL_DATA} $${file} ${PREFIX}/moscow_ml/examples/$${sdirs}; \
done; done;)
improvementsMatthias Andree2020-04-191-7/+16 * Tools/scripts/sed_checked.sh: reword sed warningMatthias Andree2020-01-121-1/+1 * Add QA warning about useless REINPLACE_CMDSteve Wills2020-01-091-0/+13 * Tools/scripts/bump_revision.pl: Fix a few issuesMatthias Andree2020-01-051-4/+6 * Tools/scripts/bump_revision.pl: Fix typo in commentMatthias Andree2020-01-051-1/+1 * Update supported version of FreeBSDBaptiste Daroussin2019-09-131-16/+8 * Stop documenting scripts which no longer lives in the treeBaptiste Daroussin2019-09-051-17/+0 * Fix typos/grammar.Matthias Andree2019-07-131-3/+3 * Update bump_revision.pl.Matthias Andree2019-07-131-74/+147 * Transfer maintainership of this script to mandree@ based on conversationsGerald Pfeifer2019-07-121-1/+1 * Tools/script/addport: Fix usage with multiple directoriesLuca Pizzamiglio2019-06-101-1/+3 * Do not search only in subfolder editors but in all.Matthias Fechner2019-05-181-1/+1 * Added a script to bump PORTREVISION if a library has changed a version like l...Matthias Fechner2019-03-292-0/+109 * rmport: fix and speed up the find_expired() function.Rene Ladan2019-03-061-21/+15 * rmport: correctly deal with expired ports when the -a (find all expired) option.Rene Ladan2019-02-271-9/+17 * Make Tools/scripts/patchtool.py compatible with Python 3.xTobias Kortkamp2019-01-291-12/+18 * Revert flavour support.Chris Rees2018-12-171-2/+2 * Support flavor_EXPIRATION_DATEChris Rees2018-12-171-2/+3 * Return a bunch of tools formerly maintained by sobomax@ to the pool.Rene Ladan2018-12-045-7/+5 * rmport: if the user edited the commit message, ask again afterwards.Rene Ladan2018-10-111-4/+7 * rmport: usability fixes:Rene Ladan2018-09-161-4/+2 * Tools/scrips/rmport: improve usabilityRene Ladan2018-09-021-10/+32 * Use 'make -C' instead of saving the current working directory and thenGerald Pfeifer2018-08-201-7/+2 * Add a stronger safety belt to this script by comparing the actualGerald Pfeifer2018-08-191-0/+15 * rmport: provide default for EDITOR varialble to preventEugene Grosbein2018-08-051-0/+1 * Also report the previous line when going backwards in time.Mathieu Arnold2018-07-031-1/+3 * Remove an extra dot messing up copy and paste.Mathieu Arnold2018-06-141-1/+1 * Return Tools/scripts/portsvar.sh to the pool.Rene Ladan2018-06-021-1/+1 * Tools: add LEGALlintEitan Adler2018-05-272-0/+23 * - Do not download obsolete attachmentsSofian Brabez2018-05-221-2/+16 * Detect flavored dependencies in Tools/scripts/rmport and add myself to the co...Rene Ladan2018-03-271-1/+2 * Show errors for duplicate source entries.Bryan Drewery2018-01-261-0/+7 * Run Tools/scripts/mfh through devel/hs-ShellCheck.Mathieu Arnold2018-01-231-17/+17 * Follow up on last commit and actually allow editingMathieu Arnold2017-12-291-0/+1 * Generic FLAVORS work.Mathieu Arnold2017-11-301-1/+30 * Commit the actual patch I testedMathieu Arnold2017-11-101-1/+1 * Cleanup resurrected processing.Mathieu Arnold2017-11-101-7/+1 * Don't blame the person that removed a resurrected.Mathieu Arnold2017-11-101-1/+0 * Add braces around all if/else.Mathieu Arnold2017-11-101-2/+3 * Re-enable blame (was annotate) with svn and git support.Mathieu Arnold2017-10-301-2/+24 * The final sort was missing from some places.Mathieu Arnold2017-10-301-2/+2 * Do not add $FreeBSD$ to the patch files.Mathieu Arnold2017-08-231-3/+0 * Fix resurrected ports not being warned about if they have a new dest entry.Bryan Drewery2017-08-081-3/+4 * Allow editing commit message on failure and save it somewhere if declined.Bryan Drewery2017-06-131-1/+8 * Fix some FreeBSD.org case of bad case.Mathieu Arnold2017-05-041-1/+1 * Add some usage instructions to the top of the mfh script. In particular,Adam Weinberger2017-05-011-0/+6 * Update Tools/scripts/rmport to ignore commented out EXPIRATION_DATE linesLarry Rosenman2017-05-011-1/+1 * Fix shebang. If /usr/bin/env is used the -w flag can't be passed after perl.Emanuel Haupt2017-04-254-138/+5 * Reset pgollucci@ as maintainer after 19 months of inactivityRene Ladan2017-03-302-2/+2 * Set maintainer of these scripts to portmgr as the previous maintainers retired.Rene Ladan2017-02-134-4/+4 * - Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile soTijl Coosemans2017-02-061-1/+0 * Make sure the merge is done on the latest branch.Mathieu Arnold2017-01-041-11/+24 * Use make(1) to extract variables from a Makefile, not grep.Mathieu Arnold2016-09-081-2/+2 * Fix the '-a' option to ${PORTSDIR}/Tools/scripts/addportMatthew Seaman2016-08-171-1/+1 * Echo where the merge was done, so one can go and have a look.Mathieu Arnold2016-08-151-0/+1 * fixup last updates, and try to be better with slave ports.Mathieu Arnold2016-08-031-4/+14 * MFportsindexbuild:Antoine Brodin2016-07-171-21/+10 * Refactor a bit.Mathieu Arnold2016-06-171-4/+11 * - Update to last versionSofian Brabez2016-06-132-36/+63 * Add a script to indent make(1)'s .if/.for blocks.Mathieu Arnold2016-06-021-0/+42 * Remove a stale comment in Tools/scripts/rmportRene Ladan2016-05-181-1/+0