aboutsummaryrefslogtreecommitdiffstats
path: root/lang/mozart/files
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-05-28 22:55:21 +0800
committerolgeni <olgeni@FreeBSD.org>2001-05-28 22:55:21 +0800
commit49c31943add3ea3e48c3e54d60476a74067c90f8 (patch)
tree7d5939dc848216aad9f9105df38865c56753d726 /lang/mozart/files
parent2c01e8f0f38552b4bc6fb512e6b404978ab97730 (diff)
downloadfreebsd-ports-gnome-49c31943add3ea3e48c3e54d60476a74067c90f8.tar.gz
freebsd-ports-gnome-49c31943add3ea3e48c3e54d60476a74067c90f8.tar.zst
freebsd-ports-gnome-49c31943add3ea3e48c3e54d60476a74067c90f8.zip
Update port to version 1.2.0.
Patches are no longer needed, and part of pkg-plist is automatically generated (code "borrowed" from O'Brien's vim5 port :). I also moved the xemacs21 dependency to emacs20.
Diffstat (limited to 'lang/mozart/files')
-rw-r--r--lang/mozart/files/patch-aa11
-rw-r--r--lang/mozart/files/patch-ab14
-rw-r--r--lang/mozart/files/patch-ac20
-rw-r--r--lang/mozart/files/patch-ad29
-rw-r--r--lang/mozart/files/patch-ae24
5 files changed, 0 insertions, 98 deletions
diff --git a/lang/mozart/files/patch-aa b/lang/mozart/files/patch-aa
deleted file mode 100644
index 271a5139058e..000000000000
--- a/lang/mozart/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- mozart-orig/platform/emulator/libdp/network.cc Wed Jun 21 15:24:16 2000
-+++ platform/emulator/libdp/network.cc Wed Jun 21 15:33:49 2000
-@@ -2357,6 +2357,8 @@
- struct sockaddr_in addr1;
- #if __GLIBC__ == 2
- unsigned int length = sizeof(addr1);
-+#elif __FreeBSD__ > 2
-+ socklen_t length = sizeof(addr1);
- #else
- int length = sizeof(addr1);
- #endif
diff --git a/lang/mozart/files/patch-ab b/lang/mozart/files/patch-ab
deleted file mode 100644
index fe7331a07e56..000000000000
--- a/lang/mozart/files/patch-ab
+++ /dev/null
@@ -1,14 +0,0 @@
---- mozart-orig/platform/emulator/os.cc Wed Jun 21 15:24:20 2000
-+++ platform/emulator/os.cc Wed Jun 21 15:25:14 2000
-@@ -1399,8 +1399,10 @@
- {
- #if __GLIBC__ == 2
- int ret = accept(s,addr,(unsigned int*)addrlen);
-+#elif __FreeBSD__ > 2
-+ int ret = accept(s,addr,(socklen_t*) addrlen);
- #else
-- int ret = accept(s,addr,addrlen);
-+ int ret = accept(s,addr,(socklen_t*) addrlen);
- #endif
- if (ret >= 0)
- registerSocket(ret);
diff --git a/lang/mozart/files/patch-ac b/lang/mozart/files/patch-ac
deleted file mode 100644
index b181ed591c6f..000000000000
--- a/lang/mozart/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- mozart-orig/platform/emulator/unix.cc Wed Jun 21 15:24:22 2000
-+++ platform/emulator/unix.cc Wed Jun 21 15:25:14 2000
-@@ -1046,6 +1046,8 @@
-
- #if __GLIBC__ == 2
- unsigned int length = sizeof(addr);
-+#elif __FreeBSD__ > 2
-+ socklen_t length = sizeof(addr);
- #else
- int length = sizeof(addr);
- #endif
-@@ -1308,6 +1310,8 @@
-
- #if __GLIBC__ == 2
- unsigned int fromlen = sizeof from;
-+#elif __FreeBSD__ > 2
-+ socklen_t fromlen = sizeof from;
- #else
- int fromlen = sizeof from;
- #endif
diff --git a/lang/mozart/files/patch-ad b/lang/mozart/files/patch-ad
deleted file mode 100644
index 7dc4b9ffe6f6..000000000000
--- a/lang/mozart/files/patch-ad
+++ /dev/null
@@ -1,29 +0,0 @@
---- mozart-orig/platform/emulator/urlc.cc Wed Jun 21 15:24:22 2000
-+++ platform/emulator/urlc.cc Wed Jun 21 15:26:54 2000
-@@ -331,6 +331,8 @@
- // save local address for later use (esp. ftp PORT)
- #if __GLIBC__ == 2
- unsigned int lin_len = sizeof(lin);
-+#elif __FreeBSD__ > 2
-+ socklen_t lin_len = sizeof(lin);
- #else
- int lin_len = sizeof(lin);
- #endif
-@@ -993,6 +995,8 @@
- struct sockaddr_in rem_addr;
- #if __GLIBC__ == 2
- unsigned int local_addr_len = sizeof(local_addr);
-+#elif __FreeBSD__ > 2
-+ socklen_t local_addr_len = sizeof(local_addr);
- #else
- int local_addr_len = sizeof(local_addr);
- #endif
-@@ -1049,6 +1053,8 @@
- struct sockaddr_in pcin; // peer control connection address
- #if __GLIBC__ == 2
- unsigned int pcin_len = sizeof(pcin);
-+#elif __FreeBSD__ > 2
-+ socklen_t pcin_len = sizeof(pcin);
- #else
- int pcin_len = sizeof(pcin);
- #endif
diff --git a/lang/mozart/files/patch-ae b/lang/mozart/files/patch-ae
deleted file mode 100644
index fc0a4ecc19ce..000000000000
--- a/lang/mozart/files/patch-ae
+++ /dev/null
@@ -1,24 +0,0 @@
---- ../mozart-orig/platform/emulator/mem.cc Fri Jun 23 12:59:01 2000
-+++ platform/emulator/mem.cc Fri Jun 23 12:59:36 2000
-@@ -90,18 +90,19 @@
- // This is optional - that's kind'f not clear which evil is the
- // smallest one: rely on "choose a nearest next free address" linux
- // behaviour, or to use the discouraged 'MAP_FIXED' option;
--#if defined(LINUX_I486)
-+#if defined(LINUX_I486) || defined (__FreeBSD__)
- #define USE_AUTO_PLACEMENT
- #endif
-
- //
- #if defined(HAVE_MMAP)
-
-+#include <sys/mman.h>
-+
- #if ( !defined(MAP_ANONYMOUS) && defined(MAP_ANON) )
- #define MAP_ANONYMOUS MAP_ANON
- #endif
-
--#include <sys/mman.h>
- #include <fcntl.h>
-
- #if !defined(USE_AUTO_PLACEMENT)