aboutsummaryrefslogtreecommitdiffstats
path: root/lang/nawk/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-07-05 03:21:58 +0800
committersteve <steve@FreeBSD.org>1998-07-05 03:21:58 +0800
commit727883f552e93bf25ef0f3f85a67c9a40008d92c (patch)
tree62ed10bf5925e6dd723d78561d3e81f06c2b4dd8 /lang/nawk/Makefile
parent6bb71d7da1b522d670082951709f0c47256b1923 (diff)
downloadfreebsd-ports-gnome-727883f552e93bf25ef0f3f85a67c9a40008d92c.tar.gz
freebsd-ports-gnome-727883f552e93bf25ef0f3f85a67c9a40008d92c.tar.zst
freebsd-ports-gnome-727883f552e93bf25ef0f3f85a67c9a40008d92c.zip
Initial import of kawk.
kawk - Brian Kernighan's awk. PR: 6460 Submitted by: Josh Gilliam <josh@quick.net>
Diffstat (limited to 'lang/nawk/Makefile')
-rw-r--r--lang/nawk/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/lang/nawk/Makefile b/lang/nawk/Makefile
new file mode 100644
index 000000000000..8bb5b0ae7cc0
--- /dev/null
+++ b/lang/nawk/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: kawk
+# Version required: 98.02.11
+# Date created: 29 April 1998
+# Whom: Josh Gilliam <josh@quick.net>
+#
+# $Id$
+#
+
+DISTNAME= awk
+PKGNAME= kawk-98.02.11
+CATEGORIES= lang
+MASTER_SITES= http://cm.bell-labs.com/who/bwk/
+
+MAINTAINER= josh@quick.net
+
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+ALL_TARGET= a.out
+MAN1= kawk.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/a.out ${PREFIX}/bin/kawk
+ ${INSTALL_MAN} ${WRKSRC}/awk.1 ${PREFIX}/man/man1/kawk.1
+
+.include <bsd.port.mk>