aboutsummaryrefslogtreecommitdiffstats
path: root/lang/nawk
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-03-29 05:44:15 +0800
committerobrien <obrien@FreeBSD.org>2003-03-29 05:44:15 +0800
commit2627ce13bcedb6ad4d8e2705e44af550b277a991 (patch)
tree8f6f6ebb28bf741641a0744f89f9ad6fab7aa647 /lang/nawk
parente00c6eb1f611a433769578936b2507a0ac5eff21 (diff)
downloadfreebsd-ports-gnome-2627ce13bcedb6ad4d8e2705e44af550b277a991.tar.gz
freebsd-ports-gnome-2627ce13bcedb6ad4d8e2705e44af550b277a991.tar.zst
freebsd-ports-gnome-2627ce13bcedb6ad4d8e2705e44af550b277a991.zip
Update to the Mar 14, 2003 version:
the internationalization changes, somewhat modified, are now reinstated. in theory awk will now do character comparisons and case conversions in national language, but "." will always be the decimal point separator on input and output regardless of national language. isblank(){} has an #ifndef. fixed subtle behavior in field and record splitting: if FS is a single character and RS is not empty, \n is NOT a separator. this tortuous reading is found in the awk book; behavior now matches gawk and mawk.
Diffstat (limited to 'lang/nawk')
-rw-r--r--lang/nawk/Makefile4
-rw-r--r--lang/nawk/distinfo2
-rw-r--r--lang/nawk/files/patch-aa2
-rw-r--r--lang/nawk/files/patch-ba12
4 files changed, 5 insertions, 15 deletions
diff --git a/lang/nawk/Makefile b/lang/nawk/Makefile
index 11002e8c806c..4b2d9c1f11c1 100644
--- a/lang/nawk/Makefile
+++ b/lang/nawk/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= nawk
-PORTVERSION= 20021213
+PORTVERSION= 20030314
CATEGORIES= lang
MASTER_SITES= http://cm.bell-labs.com/who/bwk/
DISTNAME= awk
@@ -26,3 +26,5 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/nawk.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
+
+CFLAGS+= -DHAS_ISBLANK
diff --git a/lang/nawk/distinfo b/lang/nawk/distinfo
index e377148b4622..e9423fc644b5 100644
--- a/lang/nawk/distinfo
+++ b/lang/nawk/distinfo
@@ -1 +1 @@
-MD5 (awk.tar.gz) = b6eb71ba506bc264144672d02a0d2e85
+MD5 (awk.tar.gz) = a15a10c19d154686572612ba0812cc14
diff --git a/lang/nawk/files/patch-aa b/lang/nawk/files/patch-aa
index 90a6473df217..9667edefc9e6 100644
--- a/lang/nawk/files/patch-aa
+++ b/lang/nawk/files/patch-aa
@@ -17,7 +17,7 @@
-CC = /opt/pure/purify/purify cc
-CC = cc
+CC ?= cc
-+CC := ${CC} -Wall -g -Wwrite-strings
++CC := ${CC} -Wall -g -Wwrite-strings -DHAS_ISBLANK
+#CC = gcc -Wall -g
+#CC = /opt/SUNWspro/bin/cc
+#CC = /opt/pure/purify/purify cc
diff --git a/lang/nawk/files/patch-ba b/lang/nawk/files/patch-ba
deleted file mode 100644
index 7b5724ec3ef3..000000000000
--- a/lang/nawk/files/patch-ba
+++ /dev/null
@@ -1,12 +0,0 @@
---- b.c.orig Sun Sep 24 17:18:38 2000
-+++ b.c Fri Nov 3 01:59:32 2000
-@@ -27,6 +27,9 @@
- #define DEBUG
-
- #include <ctype.h>
-+#ifdef __FreeBSD__
-+#include <limits.h>
-+#endif
- #include <stdio.h>
- #include <string.h>
- #include <stdlib.h>