aboutsummaryrefslogtreecommitdiffstats
path: root/lang/nwcc
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2007-10-15 22:37:43 +0800
committerobrien <obrien@FreeBSD.org>2007-10-15 22:37:43 +0800
commitf6da7c88b18187da680e3c54d1aaf654a58a7917 (patch)
treecece653b62d2d15b46c9fa1e6bc5afe8a5135b49 /lang/nwcc
parentc0f1c32f12eac4eceebb3348d46b680ba1f24e46 (diff)
downloadfreebsd-ports-gnome-f6da7c88b18187da680e3c54d1aaf654a58a7917.tar.gz
freebsd-ports-gnome-f6da7c88b18187da680e3c54d1aaf654a58a7917.tar.zst
freebsd-ports-gnome-f6da7c88b18187da680e3c54d1aaf654a58a7917.zip
nwcc is a small C compiler for Unix systems under the BSDL
It works with FreeBSD/OpenBSD/Solaris/Linux on 80x86, FreeBSD/Linux on AMD64, Solaris on SPARC, AIX on PowerPC, and IRIX on MIPS hardware. The x86 and AMD64 backends support two assemblers; nasm/yasm and gas.
Diffstat (limited to 'lang/nwcc')
-rw-r--r--lang/nwcc/Makefile29
-rw-r--r--lang/nwcc/distinfo3
-rw-r--r--lang/nwcc/pkg-descr12
-rw-r--r--lang/nwcc/pkg-plist11
4 files changed, 55 insertions, 0 deletions
diff --git a/lang/nwcc/Makefile b/lang/nwcc/Makefile
new file mode 100644
index 000000000000..56adf2931a7b
--- /dev/null
+++ b/lang/nwcc/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: pcc
+# Date created: Mon Oct 15, 2007
+# Whom: David O'Brien (obrien@NUXI.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= nwcc
+PORTVERSION= 0.7.3
+PORTREVISION?= 0
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= obrien@FreeBSD.org
+COMMENT= Nils Weller's C compiler for Unix systems
+
+ONLY_FOR_ARCHS= i386 amd64
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --installprefix=${PREFIX}
+ALL_TARGET=
+
+post-build:
+ cd ${WRKSRC} ; ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/lang/nwcc/distinfo b/lang/nwcc/distinfo
new file mode 100644
index 000000000000..f85473081926
--- /dev/null
+++ b/lang/nwcc/distinfo
@@ -0,0 +1,3 @@
+MD5 (nwcc_0.7.3.tar.gz) = 7cb8f5cfb53ae613b9721061bf1f73f9
+SHA256 (nwcc_0.7.3.tar.gz) = 7d9ac069b42f5834e06162452d9008e1f07aaee85a81c81b5b8a0645dfb8d585
+SIZE (nwcc_0.7.3.tar.gz) = 521398
diff --git a/lang/nwcc/pkg-descr b/lang/nwcc/pkg-descr
new file mode 100644
index 000000000000..dd9ec1d5bdf5
--- /dev/null
+++ b/lang/nwcc/pkg-descr
@@ -0,0 +1,12 @@
+nwcc is a small C compiler for Unix systems under the BSDL
+
+The primary goals of nwcc currently are portability and correctness.
+Various C99 and GNU C features are also supported.
+
+It works with FreeBSD/OpenBSD/Solaris/Linux on 80x86, FreeBSD/Linux on AMD64,
+Solaris on SPARC, AIX on PowerPC, and IRIX on MIPS hardware.
+Cross-compilation is also supported.
+The x86 and AMD64 backends support two assemblers; nasm/yasm and gas.
+This can be useful for side-by-side assembler syntax comparison
+
+WWW: http://nwcc.sourceforge.net/
diff --git a/lang/nwcc/pkg-plist b/lang/nwcc/pkg-plist
new file mode 100644
index 000000000000..6e00a0505511
--- /dev/null
+++ b/lang/nwcc/pkg-plist
@@ -0,0 +1,11 @@
+$FreeBSD$
+bin/nwcc
+bin/nwcc1
+lib/libnwcc.o
+nwcc/bin/nwcc
+nwcc/bin/nwcc1
+nwcc/bin/snake
+nwcc/lib/libnwcc.o
+@dirrm nwcc/lib
+@dirrm nwcc/bin
+@dirrm nwcc