aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-07-04 22:50:07 +0800
committermi <mi@FreeBSD.org>2005-07-04 22:50:07 +0800
commitdb1ff915a4b52b2272c99dab60f776938379ed58 (patch)
tree48ab9adf390bbbe2d91561c1ec74aa44bd83bbd4 /lang/ocaml
parent12901b9450652912ae6842fd2c213e69a9fe7c1a (diff)
downloadfreebsd-ports-gnome-db1ff915a4b52b2272c99dab60f776938379ed58.tar.gz
freebsd-ports-gnome-db1ff915a4b52b2272c99dab60f776938379ed58.tar.zst
freebsd-ports-gnome-db1ff915a4b52b2272c99dab60f776938379ed58.zip
Don't try to fix compile flags on sparc64 and just mark the port broken
on the platform -- ocamlc.opt keeps seg-faulting even with `-O0 -g' even on 5-stable. Patch(es) needed. Notified by: Peter van Dijk
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 68364eb1edbe..d191d17bda52 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -90,6 +90,9 @@ MODOPT= camlp4o camlp4r ocamlc ocamldep ocamldoc ocamllex ocamlopt
.include <bsd.port.pre.mk>
+.if ${MACHINE_ARCH} == sparc64
+BROKEN= ocamlc.opt seg-faults on ${MACHINE_ARCH}, please try to fix
+.endif
PLIST_SUB+= PROF=""
post-configure:
@@ -99,9 +102,6 @@ post-configure:
-e 's|(NATIVECCCOMPOPTS[[:space:]]*=.*)|\1 ${CFLAGS}|' \
-e 's|gcc|${CC}|g' \
${WRKSRC}/config/Makefile
-.if ${MACHINE_ARCH} == sparc64
- @${REINPLACE_CMD} -e 's,-O2,-O,g' ${WRKSRC}/config/Makefile
-.endif
# INSTALL* safeness (which preserves the correct permissions despite
# user's umask(1)
@${FIND} ${WRKDIR} -type f -name Makefile -print0 | \