aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-05-22 03:57:07 +0800
committersem <sem@FreeBSD.org>2005-05-22 03:57:07 +0800
commit5fb39babf8cf13d85de360e35ac8bfe6d70758eb (patch)
tree707cee08bf71fbf62e2e3c9f254c6f28771f6d5d /lang/ocaml
parentaa2bee89bf77b44755eb9f5f6d6d724c9aabc63c (diff)
downloadfreebsd-ports-gnome-5fb39babf8cf13d85de360e35ac8bfe6d70758eb.tar.gz
freebsd-ports-gnome-5fb39babf8cf13d85de360e35ac8bfe6d70758eb.tar.zst
freebsd-ports-gnome-5fb39babf8cf13d85de360e35ac8bfe6d70758eb.zip
- Fix permission of ld.conf. It should be 0644 instead of 0444.
- Unbreak unguilty ports.
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile12
-rw-r--r--lang/ocaml/pkg-plist68
2 files changed, 37 insertions, 43 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 066dc2807231..77fc9c3655dc 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ocaml
PORTVERSION= 3.08.3
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME:R}/ \
ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME:R}/ \
@@ -132,17 +133,10 @@ post-install:
ocamllex.opt ocamlopt.opt ocamlrun ocamlyacc
@${STRIP_CMD} ${PREFIX}/bin/${prog}
.endfor
-# XXX ugly hack to fix permissions. I could not find the proper
-# Makefile entry
-
+# XXX ugly hack to fix permissions.
@${FIND} ${EXAMPLESDIR} -type f -print0 | \
${XARGS} -0 -n 5 -x \
${CHMOD} ${SHAREMODE}
- @${FIND} -d ${EXAMPLESDIR} -type d -print0 | \
- ${XARGS} -0 -n 5 -x \
- ${CHMOD} ${SHAREMODE}
- @${FIND} -s ${EXAMPLESDIR} -type d -print0 | \
- ${XARGS} -0 -n 5 -x \
- ${CHMOD} a+x
+ @${CHMOD} u+w ${PREFIX}/lib/ocaml/ld.conf
.include <bsd.port.post.mk>
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index 50ef163ce9f8..b62542344ce8 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -887,40 +887,40 @@ lib/ocaml/weak.cmx
lib/ocaml/weak.ml
lib/ocaml/weak.mli
%%PROF%%lib/ocaml/weak.p.cmx
-%%TK%%share/examples/ocaml/camltk/Makefile
-%%TK%%share/examples/ocaml/camltk/Makefile.nt
-%%TK%%share/examples/ocaml/camltk/addition.ml
-%%TK%%share/examples/ocaml/camltk/eyes.ml
-%%TK%%share/examples/ocaml/camltk/fileinput.ml
-%%TK%%share/examples/ocaml/camltk/fileopen.ml
-%%TK%%share/examples/ocaml/camltk/helloworld.ml
-%%TK%%share/examples/ocaml/camltk/images/CamlBook.gif
-%%TK%%share/examples/ocaml/camltk/images/Lambda2.back.gif
-%%TK%%share/examples/ocaml/camltk/images/dojoji.back.gif
-%%TK%%share/examples/ocaml/camltk/jptest.ml
-%%TK%%share/examples/ocaml/camltk/mytext.ml
-%%TK%%share/examples/ocaml/camltk/socketinput.ml
-%%TK%%share/examples/ocaml/camltk/taddition.ml
-%%TK%%share/examples/ocaml/camltk/tetris.ml
-%%TK%%share/examples/ocaml/camltk/text.ml
-%%TK%%share/examples/ocaml/camltk/winskel.ml
-%%TK%%share/examples/ocaml/labltk/Lambda2.back.gif
-%%TK%%share/examples/ocaml/labltk/Makefile
-%%TK%%share/examples/ocaml/labltk/Makefile.nt
-%%TK%%share/examples/ocaml/labltk/README
-%%TK%%share/examples/ocaml/labltk/calc.ml
-%%TK%%share/examples/ocaml/labltk/clock.ml
-%%TK%%share/examples/ocaml/labltk/demo.ml
-%%TK%%share/examples/ocaml/labltk/eyes.ml
-%%TK%%share/examples/ocaml/labltk/hello.ml
-%%TK%%share/examples/ocaml/labltk/hello.tcl
-%%TK%%share/examples/ocaml/labltk/lang.ml
-%%TK%%share/examples/ocaml/labltk/taquin.ml
-%%TK%%share/examples/ocaml/labltk/tetris.ml
-%%TK%%@dirrm share/examples/ocaml/labltk
-%%TK%%@dirrm share/examples/ocaml/camltk/images
-%%TK%%@dirrm share/examples/ocaml/camltk
-%%TK%%@dirrm share/examples/ocaml
+%%TK%%%%EXAMPLESDIR%%/camltk/Makefile
+%%TK%%%%EXAMPLESDIR%%/camltk/Makefile.nt
+%%TK%%%%EXAMPLESDIR%%/camltk/addition.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/eyes.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/fileinput.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/fileopen.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/helloworld.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/images/CamlBook.gif
+%%TK%%%%EXAMPLESDIR%%/camltk/images/Lambda2.back.gif
+%%TK%%%%EXAMPLESDIR%%/camltk/images/dojoji.back.gif
+%%TK%%%%EXAMPLESDIR%%/camltk/jptest.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/mytext.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/socketinput.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/taddition.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/tetris.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/text.ml
+%%TK%%%%EXAMPLESDIR%%/camltk/winskel.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/Lambda2.back.gif
+%%TK%%%%EXAMPLESDIR%%/labltk/Makefile
+%%TK%%%%EXAMPLESDIR%%/labltk/Makefile.nt
+%%TK%%%%EXAMPLESDIR%%/labltk/README
+%%TK%%%%EXAMPLESDIR%%/labltk/calc.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/clock.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/demo.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/eyes.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/hello.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/hello.tcl
+%%TK%%%%EXAMPLESDIR%%/labltk/lang.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/taquin.ml
+%%TK%%%%EXAMPLESDIR%%/labltk/tetris.ml
+%%TK%%@dirrm %%EXAMPLESDIR%%/labltk
+%%TK%%@dirrm %%EXAMPLESDIR%%/camltk/images
+%%TK%%@dirrm %%EXAMPLESDIR%%/camltk
+%%TK%%@dirrm %%EXAMPLESDIR%%
@dirrm lib/ocaml/vmthreads
@dirrm lib/ocaml/threads
@dirrm lib/ocaml/stublibs