aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ofc/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-07-28 12:20:32 +0800
committervanilla <vanilla@FreeBSD.org>2013-07-28 12:20:32 +0800
commitea9eb3f202d192299cbad5e8b120054399a66134 (patch)
treed171f88c95bcca0aaa449e8d703fb97dbd1dbec7 /lang/ofc/Makefile
parent1bb76c38e18e6c1b067139aeb754b86335be8bb2 (diff)
downloadfreebsd-ports-gnome-ea9eb3f202d192299cbad5e8b120054399a66134.tar.gz
freebsd-ports-gnome-ea9eb3f202d192299cbad5e8b120054399a66134.tar.zst
freebsd-ports-gnome-ea9eb3f202d192299cbad5e8b120054399a66134.zip
1: Fix build with newer zlib [1]
2: switch to gcc46. PR: ports/180748 Submitted by: John Marino <freebsd at marino.st> [1]
Diffstat (limited to 'lang/ofc/Makefile')
-rw-r--r--lang/ofc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 1b3cea22b28f..0b4e9cb4ca1b 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
PROJECTHOST= ${PORTNAME}
USE_SDL= sdl
USE_AUTOTOOLS= libtool
-USES= pathfix
+USES= pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
@@ -38,7 +38,7 @@ LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
.if ${OSVERSION} >= 900000
# needs libobjc
-GCCSUFFIX=42
+GCCSUFFIX= 46
CC= gcc${GCCSUFFIX}
CXX= g++${GCCSUFFIX}
OFC_GCC_PORT?= lang/gcc${GCCSUFFIX}