aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ofc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-02 08:56:45 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-02 08:56:45 +0800
commit816517e4bd2d268cfe29d4887418d56cbb133e9a (patch)
tree0741b832fd7d93cb86679acc0268852b051859db /lang/ofc
parent20cab9b983c34c9e4300eeb222d9df6612c4e24e (diff)
downloadfreebsd-ports-gnome-816517e4bd2d268cfe29d4887418d56cbb133e9a.tar.gz
freebsd-ports-gnome-816517e4bd2d268cfe29d4887418d56cbb133e9a.tar.zst
freebsd-ports-gnome-816517e4bd2d268cfe29d4887418d56cbb133e9a.zip
Mark as broken on gcc4.2. While here, pet portlint.
Diffstat (limited to 'lang/ofc')
-rw-r--r--lang/ofc/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 8cf8197c6245..c8825a352c6e 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -18,13 +18,19 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= GDBM "Add gdbm support" off \
GMP "Add gmp support" off
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if defined (WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
.endif
@@ -33,4 +39,4 @@ LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
LIB_DEPENDS+= gmp.4:${PORTSDIR}/math/libgmp4
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>