aboutsummaryrefslogtreecommitdiffstats
path: root/lang/open-cobol-devel/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-11-20 21:00:57 +0800
committerijliao <ijliao@FreeBSD.org>2002-11-20 21:00:57 +0800
commit7811bbe5d7af9c7e74d8c77fd5891e35ec4745fb (patch)
tree856883ebc57b508c697a9029c40df6cbc841adf2 /lang/open-cobol-devel/Makefile
parentfb66fa9f633142ff9d5b8920828bb55b321c6815 (diff)
downloadfreebsd-ports-gnome-7811bbe5d7af9c7e74d8c77fd5891e35ec4745fb.tar.gz
freebsd-ports-gnome-7811bbe5d7af9c7e74d8c77fd5891e35ec4745fb.tar.zst
freebsd-ports-gnome-7811bbe5d7af9c7e74d8c77fd5891e35ec4745fb.zip
- Fix LIB_DEPENDS
- Do not install useless .la files PR: 45443 Submitted by: Ports Fury
Diffstat (limited to 'lang/open-cobol-devel/Makefile')
-rw-r--r--lang/open-cobol-devel/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index c2489b35bdaa..1a4e30e5afe7 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -8,22 +8,25 @@
PORTNAME= open-cobol
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
- iconv:${PORTSDIR}/converters/libiconv \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt \
- db4:${PORTSDIR}/databases/db4 \
+LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4 \
+ intl.4:${PORTSDIR}/devel/gettext \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ ltdl.1:${PORTSDIR}/devel/libtool \
gmp.6:${PORTSDIR}/math/libgmp4
-USE_REINPLACE= yes
USE_BISON= yes
-USE_LIBTOOL= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
CONFIGURE_ARGS= --with-readline
INSTALLS_SHLIB= yes