aboutsummaryrefslogtreecommitdiffstats
path: root/lang/open-cobol/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-01-04 01:55:27 +0800
committerarved <arved@FreeBSD.org>2003-01-04 01:55:27 +0800
commita50268d00196eeb658505540d76ad827cc822da5 (patch)
treec1f5d1d396fb33ac5e182daeba9da2af508c0575 /lang/open-cobol/Makefile
parent3e92ebc309a16f7e87a9abfa769971d10b5cea13 (diff)
downloadfreebsd-ports-gnome-a50268d00196eeb658505540d76ad827cc822da5.tar.gz
freebsd-ports-gnome-a50268d00196eeb658505540d76ad827cc822da5.tar.zst
freebsd-ports-gnome-a50268d00196eeb658505540d76ad827cc822da5.zip
Update to 0.10
PR: 46307 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'lang/open-cobol/Makefile')
-rw-r--r--lang/open-cobol/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 1a4e30e5afe7..699124308985 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -7,30 +7,30 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 0.10
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4 \
- intl.4:${PORTSDIR}/devel/gettext \
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
ltdl.1:${PORTSDIR}/devel/libtool \
gmp.6:${PORTSDIR}/math/libgmp4
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-USE_BISON= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_ARGS= --with-readline
INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e "s|-ldb|-ldb4|g" ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
.include <bsd.port.mk>