aboutsummaryrefslogtreecommitdiffstats
path: root/lang/open-cobol
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-05-15 02:23:48 +0800
committerthierry <thierry@FreeBSD.org>2005-05-15 02:23:48 +0800
commit0cf9078e3060740af4901086c52c9a28fc72a054 (patch)
tree2d541f548c8b4d50488dae7ccab68df78df65a77 /lang/open-cobol
parent8d861242f3b987fb8b2f68bf3c2f6c588635775d (diff)
downloadfreebsd-ports-gnome-0cf9078e3060740af4901086c52c9a28fc72a054.tar.gz
freebsd-ports-gnome-0cf9078e3060740af4901086c52c9a28fc72a054.tar.zst
freebsd-ports-gnome-0cf9078e3060740af4901086c52c9a28fc72a054.zip
- Upgrade to 0.32;
Changelog at <http://sourceforge.net/project/shownotes.php?release_id=326779> - Add a test target.
Diffstat (limited to 'lang/open-cobol')
-rw-r--r--lang/open-cobol/Makefile9
-rw-r--r--lang/open-cobol/distinfo4
-rw-r--r--lang/open-cobol/files/patch-tests_atlocal.in11
3 files changed, 21 insertions, 3 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 75c492113156..c89a8f81dda2 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.31
+PORTVERSION= 0.32
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -44,4 +44,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
${WRKSRC}/cobc/Makefile.in
+.if defined(MAINTAINER_MODE)
+test: build
+ (cd ${WRKSRC}/tests; \
+ ./syntax; \
+ ./run)
+.endif
+
.include <bsd.port.mk>
diff --git a/lang/open-cobol/distinfo b/lang/open-cobol/distinfo
index 50a1cf69990c..ebf8c07fdebf 100644
--- a/lang/open-cobol/distinfo
+++ b/lang/open-cobol/distinfo
@@ -1,2 +1,2 @@
-MD5 (open-cobol-0.31.tar.gz) = 18aeeb41595c3e03b2c315a5c12d5ee6
-SIZE (open-cobol-0.31.tar.gz) = 751754
+MD5 (open-cobol-0.32.tar.gz) = 9ffc3b75eca988e40206b3e310bba635
+SIZE (open-cobol-0.32.tar.gz) = 768635
diff --git a/lang/open-cobol/files/patch-tests_atlocal.in b/lang/open-cobol/files/patch-tests_atlocal.in
new file mode 100644
index 000000000000..e902d53ba8b2
--- /dev/null
+++ b/lang/open-cobol/files/patch-tests_atlocal.in
@@ -0,0 +1,11 @@
+--- tests/atlocal.in.orig Tue May 3 11:31:14 2005
++++ tests/atlocal.in Sat May 14 18:24:52 2005
+@@ -10,7 +10,7 @@
+ COMPILE_ONLY="${COBC} -fsyntax-only ${FLAGS}"
+ COMPILE_MODULE="${COBC} -m ${FLAGS}"
+
+-export COB_CFLAGS="-I${abs_top_srcdir}"
++export COB_CFLAGS="-I${abs_top_srcdir} -I@prefix@/include"
+ export COB_LIBS="-L${abs_top_builddir}/libcob/.libs -lcob @LIBCOB_LIBS@"
+ export COB_CONFIG_DIR="${abs_top_srcdir}/config"
+ export LD_LIBRARY_PATH="${abs_top_builddir}/libcob/.libs"