aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p2c/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-03-04 14:46:27 +0800
committerwen <wen@FreeBSD.org>2016-03-04 14:46:27 +0800
commit9f81556ab14155e96b1c874c9eb6a998e3bb1281 (patch)
tree4ce521c704b8e310c187ebba0f831881637b97f9 /lang/p2c/Makefile
parentd96a82c745afa8f31078e165b551a4094dad99c2 (diff)
downloadfreebsd-ports-gnome-9f81556ab14155e96b1c874c9eb6a998e3bb1281.tar.gz
freebsd-ports-gnome-9f81556ab14155e96b1c874c9eb6a998e3bb1281.tar.zst
freebsd-ports-gnome-9f81556ab14155e96b1c874c9eb6a998e3bb1281.zip
- Update to 2.01
PR: 205212 Submitted by: tkato432@yahoo.com
Diffstat (limited to 'lang/p2c/Makefile')
-rw-r--r--lang/p2c/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/lang/p2c/Makefile b/lang/p2c/Makefile
index 8737efb36ec2..231565789a95 100644
--- a/lang/p2c/Makefile
+++ b/lang/p2c/Makefile
@@ -2,27 +2,29 @@
# $FreeBSD$
PORTNAME= p2c
-PORTVERSION= 1.21a
-PORTREVISION= 3
+PORTVERSION= 2.01
CATEGORIES= lang
-MASTER_SITES= http://darkstar.ist.utl.pt/slackware/slackware_source/d/p2c/ \
- http://www.slackware.at/data/slackware-10.0/source/d/p2c/
-DISTFILES= p2c-1.21alpha2.tar.gz
+MASTER_SITES= https://schneider.ncifcrf.gov/p2c/
MAINTAINER= ports@FreeBSD.org
COMMENT= Pascal to C translator
-BROKEN= unfetchable
-
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/p2c-1.21alpha-07.Dec.93/src
+WRKSRC_SUBDIR= src
USES= perl5 shebangfix
SHEBANG_FILES= p2cc.perl
perl_OLD_CMD= /bin/perl
+USE_PERL5= run
ALL_TARGET= all p2cc
+pre-build:
+ @${RM} -f ${WRKSRC}/p2c.man.inst
+
+post-build:
+ @${LN} -sf p2c.man.inst ${WRKSRC}/p2c.1
+
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} p2c \
${STAGEDIR}${PREFIX}/bin)
@@ -40,5 +42,7 @@ do-install:
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} \
${STAGEDIR}${PREFIX}/lib/p2c)
.endfor
+ (cd ${WRKSRC} && ${INSTALL_MAN} p2c.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
.include <bsd.port.mk>