aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p5-ExtUtils-F77/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /lang/p5-ExtUtils-F77/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'lang/p5-ExtUtils-F77/Makefile')
-rw-r--r--lang/p5-ExtUtils-F77/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/p5-ExtUtils-F77/Makefile b/lang/p5-ExtUtils-F77/Makefile
index 5dc3f9db1d6d..92899a77ade8 100644
--- a/lang/p5-ExtUtils-F77/Makefile
+++ b/lang/p5-ExtUtils-F77/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
#
-PORTNAME= p5-ExtUtils-F77
+PORTNAME= ExtUtils-F77
PORTVERSION= 1.12
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ExtUtils
-DISTNAME= ExtUtils-F77-1.12
+PKGNAMEPREFIX= p5-
MAINTAINER= jmz@FreeBSD.org
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= ExtUtils::F77.3
@@ -27,10 +27,10 @@ F2CLIB= -lf2c
.endif
post-patch:
- @(cd ${WRKSRC}; ${MV} -f F77.pm F77.pm~; \
- ${PERL5} -e 'while(<>){s/(.*Freebsd.*lib )(-lf2c)(.*)/$$1 ${F2CLIB} $$3/;print $$_;}' < F77.pm~ > F77.pm)
+ @cd ${WRKSRC}; ${PERL5} -i.orig -pe \
+ 's/(.*Freebsd.*lib )(-lf2c)(.*)/$$1 ${F2CLIB} $$3/' F77.pm
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.post.mk>